Alternative Firmware (Debian Jessie, Synology DSM6)


#318

Hello I have my Cloud Mirror Gen1 with DSM-wdmc-mirror-8451.pat installed from you Gdrive.
I have seen that 6.1 is out.
Can I just make an online update from DSM Panel? or should I install a pat file? If so which one ? Thanks @Fox_exe


#319

DSM 6 for Gen1 not boot. Need fix some weird thing in kernel.


#320

You are right, on my Linux server, I also use the immutable flag to prevent accidental deletion or modification of some files. It would however be more interesting to find out why and how the files are changed by the system.
@Fox_exe
I just wonder why not use auditd with diff to see what happens and why?


#321

Is there an update path from your previous DSM release to this one? Your instructions are from WD firmware to DSM, but for that I’m certain to lose my data. Is it possible/recommended to try an update without losing my data?


#322

Hi,
just got a Ultra EX2 and flashed it to DSM :slight_smile:
Thanks a lot for that option btw - 2 minutes with the WD gui made me realize I needed another level of interaction.

Initially everything has worked, but then I started dabbling with multi-homing. Even that worked fine after some tinkering so I started copying data to the box. I ran rsync for the night and then logged in this morning to check whether it was finished.
I could login to the GUI but noticed that it didn’t update the utilization widgets. So I rebooted it using the menu and now can’t login any more - all I get is a blank window.
Tried ssh’ing in - connection refused (worked fine yesterday).
Tried resetting IPs again - no change.
Tried 40s reset - no change.

Any idea what else I could try before I take it apart to try FTDI access?

Thanks


#323

Just unplug HDD’s and turn on WD. Device will boot into DSM Installer. (Plug back HDD’s and reinstall DSM. Files will be saved, but all settings will lost).


#324

Great, thanks a lot :smiley:
Too bad I couldn’t get any logs from the box before reinstalling. Not a biggie to reinstall every other week if it keeps the data but o/c its better not to have to.
Would this kind of error be sent to a syslog server? Would the error log be accessible via SNMP maybe?
Or is it not really of interest?:wink:


#325

So after a few more days I have to say this release is not yet stable for me.
Not sure what it is, but at some point the GUI always begins to act up (last time I couldn’t add users any more) and when I then run reboot (from gui or cli) I will not reboot. When I run poweroff from cli it will not poweroff either.
I then cut power and reboot - Gui is blank, SSH is up but denying login (no prompt) and I basically have to reinstall.

Not sure if I do something wrong to be honest (trying unsupported functionality?), but in fact I am not doing much.
The only thing I did was copy files (and now its indexing videos/photos) and I activated VLAN support to enable multihoming…


#326

Do you have the UART working on a MyCloud single drive gen2 system?


#327

Is it confirmed the DL2100 is working with this firmware? I can’t find the answer in the thread. Thanks!


#328

Hi Fox

Thanks for the awesome work!

Please excuse my newb question.

I have DSM 5 installed on my MyCloud Gen1. Can you tell me how to change the language I receive my email in from Russian (I Think) to English?

When I connect to the NAS via Putty I get a BusyBox v1.16.1 Shell but don’t seem to be able to use any of the standard Debian commands to change the default language.

JohnB


#329

Somewhere down the line in the last 3 weeks of unattended idling I lost my volume - no biggie since its just a copy but makes me wonder how safe this version is yet.
Any pointers on how to debug this issue?

Edit: I rebooted the box and back to blank login screen - so another installation will be needed.


#330

@Fox_exe
Any pointers to debugging this you can give?
I’d really love to use this but in this state its totally useless :cry:


#331

@Fox_exe
I would like to install OMV or DSM. They will fit into the flash only (to avoid continuous hd work)? How stable is DSM? I really like its web-ui. Does it implement the fan control like debian using mgm-fancontrol or similar?
There is any guide that I can follow to build by my own the DSM?


#332

For now - we have one big problem - From time to time 4 files are damaged. Need find why this happend and fix… Or make some “workaround”: Block these files from change or monitor changes and replace from backup if changed/damaged.


#333

Well if we know which 4 files these are it should be no issue to have a cron job replace them from a backup whenever a crc check fails or something similar.
Do you know which ones get corrupted?


#334

Hi !

is the firmware wd-to-dsm.bin also compatible with the my cloud ex2 ultra ? Can i install this firmware too ?

Any answer would be nice and also how stable is this system ?
and what is DSM-wdmc-mirror-gen2-8451.pat 220 mb file ?

Its very nice that the Fox_exe is sharing all the stuff but there is no explanation how to use all the stuff :slight_smile:
i have only basic knowledge with debian.

Also it would be perfect if any smart person here could explain how to make "own apps " Can i use the wd system via ssh to make app or do i need any additional tools or an own virtual debian linux system to compile apps ?

Frank


#335

Sure!

/usr/lib/libfileindex.so /usr/lib/libsynopkg.so /usr/lib/libsynoshare.so /usr/lib/libsynostoragemgmt.so
Original files for DSM 6.1 (build 8451)


#336

Nope. Need different DTB file in kernel (Becase Ex2 Ultra have more Ram) and another version string in firmware file.
**.pat - Original Synology firmware file, modified by me for compatable with our hardware (Replaced installer and libs, removed some checks, bootloader upgrade and other stuff)

Need packager program from “Firmware Source code” archive.
Also need some linux for compile software (“Cross compile” for “armhf” | Cortex-A9/FPU/VFP-V3/NEON)
Or just use precompiled soft for armel/armhf (From Debian or RaspberryPI). Maybe need replace some libs, because its too old in firmware.


#337

Now I am confused - in http://anionix.ddns.net/WDMyCloud/WDMyCloud-Ex2-Ultra/Info.txt you say that Ex2 Ultra and Mirror Gen2 are the same (“Look for WDMyCloud-Mirror-Gen2 (Its same device. Just marketing :D)”).

Here you said that this won’t work on Ultra EX2 - thats actually the box I use as well… :confused: