Almost sleeping through the night - A good sign

With only the occasional glitch, such as the initialization that takes 3 hours and in my panic I do the 40 second reset 3 times during that initialization, not realizing that I should let it initialize (hey I am a user that does user things),  I’ve been pretty happy with the two WD Products that I own.

Now I’m even happier after waking up my drive to check my user.log to find… with just stopping all the services that I list in my “sleep post” including Cron services,  my drive surprised me with great sleep time (this is like a hang time except for WD devices).  

I don’t always get great sleep time, but for some strange reason after my last reboot which was caused by plugging in my USB drive, then getting a lock up, and after going through the whole ritual of letting the drive boot up normally and settling down before plugging in my USB drive, then letting that settle down… then making sure that media scan is off (which it was automatically), then stopping all the unneeded services, my drive got great sleep time yesterday night. Don’t ask me which part of the ritual (perhaps it was the facing west) before plugging in the USB drive, that did it.

Here is my drive user.log from last night till now.

Apr 6 08:20:24 WDMyCloud logger: exit standby after 16983 (since 2014-04-06 03:37:21.126452000 -0700)
Apr 6 08:36:44 WDMyCloud logger: exit standby after 677 (since 2014-04-06 08:25:27.236452000 -0700)
exec: No such file or directory
Apr 6 15:48:20 WDMyCloud logger: exit standby after 25593 (since 2014-04-06 08:41:47.126452000 -0700)


4 hours and 43 minutes from 3:37am till 8:20am this morning

and ignoring the 11 minute wake up

7 hours and 6 minutes from 8:41 till 3:48pm

This shows that it can be done. Don’t let the internet and the power users tell you that it is better to let your drive run for 14 (edited by user request) years straight then to let it sleep for 4 or 7 hours straight.

You do the math, I think by sleeping for 7 hours, that is 7 hours more that I get for drive life if it is on standby.

I can agree that waking up the drive every 10 minutes and cycling it through multiple standby is bad for your drive, but  not when it is sleeping soundly.

If nothing else, I am pleased to touch a “cool to the touch” drive everytime I walk by and touch it.

Now we just have to wait till WD gets this right in their next firmware update. (It can be done).

1 Like

@ Ralphael,

“This shows that it can be done. Don’t let the internet and the power users tell you that it is better to let your drive run for 10 years straight then to let it sleep for 4 or 7 hours straight.”

Correction WD Red drives last 14 years running it 24/7/365. So are you gonna use the drive after 2028 ?

And what is:

exec: No such file or directory

In your log file ?

If you turn back on things one by one, can you find the guilty problem? Or is it all a mix of everything?

@Pacific on using the drive till 2028…

If I said yes, I probably would be lying since I’ll probably upgrade to the WD 4 exabyte drives next year :stuck_out_tongue: but it is comforting to touch a cool to the touch enclosure versus a very warm system.

After waking up my drive, I run a script to copy the user.log files to my mapped drive and the first line is

rm -f /shares/Cloudy/user.log

cp /var/log/user.log /shares/Cloudy

chmod 777 /shares/Cloudy/user.log

and if the user.log file doesn’t exist, it throws the message out to user.log saying exec: No such file or directory just before I copy it.

just another one of my daily rituals :stuck_out_tongue:

ThreeEyedMinion wrote:
If you turn back on things one by one, can you find the guilty problem? Or is it all a mix of everything?

WD uses a lot of

if [-f /tmp/standby]; then

basically saying if the file /tmp/standby exist then do something… To set a flag all they have to do is

touch /tmp/standby

and an empty file is created.

This is also how they know that your system is ready by the following loop…

wait_system_ready() {

    while [! -f “/tmp/ready”]; do

        logger -s “$0: waiting for system to become ready…”

        sleep 5



Thus if you kill off a bunch of services without knowing the consequences, flags don’t get set or flags don’t get erased, which means that other programs that perhaps waits for the services, will basically hang. 

I’ve had mixed results from clean boots, with no services stopped and still my sleeping pattern is erratic.

This time, it is still a clean boot and letting all services execute for “X” amount of time as well as letting the system run for a long time with no stopped services after connecting my USB drive, may have cleaned out any errant flags. 

The problem is that WD is faking the standby mode with under /usr/local/sbin. It turns on standby with hdparm after looping for 10 minutes and monitoring no drive activity.

Something in linux then wakes up the drive and monitorio notices that the drive is out of standby then writes the user.log message then goes back to looping for another 10 minutes. The device is never asleep which is why some review magazine says that the drive in sleep mode still consumes 5 watts of power and that is because the motherboard is still running.

It is definitely something in the regular jobs of linux that is waking up the drive and I think it is the logfiles despite the fact that WD has moved the logs over to ram drive, it still isn’t enough. 

but yes, if I face west… the drive sleeps better… 

@ Ralphael

Do you have the DLNA on?
I keep DLNA/Clud services off now, as advised by WD staff, to check if it can finally sleep (and pinpoint cause of wakeups). Noticed the same symptoms: less frequent wakeups. Not sure if it matters, but I put my books and music in separate shares (reducing number of files per share) and initially thought this helped.

I want to switch the DLNA and then Cloud to check if the NAS is still asleep as much as now - the DLNA is what I really need.

As for the user log: I assume (!) you get it via SSH. Any way to use the log generated via the web UI?