All of a sudden can't find drive (lost in space)

I would greatly appreciate any, and all help.

Windows 7

Mac G5

I have a WD passport  WD2500me-00

This thing has ALWAYS worked perfect. Today I was wondering why my WD500 gb extrernal (with external power source) was not being seen on my home network through my Airport extreme. So I wanted to try a self powering drive to see if that was the issue. (it was) The second I plugged the passport into the airport, my PC recognized it.I typed in the password for the airport, and it pulled right up.

I then tried some trouble shooting techinques to try to get the other larger drive to work. I did not properly eject the harddrive from the AIrport extreme.  I also right clicked on the mapped network drive, and said dissconnect (thinking this might help)  the drive is not seen anywhere now.

I went to “Disc Managment” its not there, I went to “device manager” and it is now listed as a “initio default controller” i even tried going to where the printers, and devices are listed. It is here again under the heading “Initio Default Controller” I tried to update the driver, and nothing. It says working properly, but nothing.

I tried plugging this into a mac, it doesnt see it (it did before) I tried plugging into 3 other computers, and it is not seen.

My assesment is it was not ejexted properly so it is essentially “stuck on” or “connect” still to the something else, and I cant get it out of that state to allow plugging in to a new state.

I do need the data on this drive, so format is not an option


I think it may be the circuit board inside. fzabkar is the only one who understands those boards. You probably should comtact WD support.


You’ve got yourself a dead hard drive. (You may not hear drive spinning) Only USB to SATA controller is functioning (Initio Default Controller). Contact WD for support. Eventually they may replace your drive. It may cost you US$ 1000 > 2000 to recover your data, if that is possible.