All checks report OK on this 8GB WD Cloud Mirror, but half the space is gone

Started with a blinking blue turning to solid red power light. This is an 8GB unit, formatted for RAID 0.
I ran System Check, after a couple of hours that finished and reported no problems. I ran Scan Disk, and that reported no problems. Everything else reports no problems.
The solid red power light went to solid blue and I could access the drive again.
I deleted everything on it and cleared the Recycle bin.
However, now the Dashboard reports about 3+GB available (usually it’s 7+GB available, other than the backups.)
It seems to be performing a normal backup operation this morning (using EaseUS Todo Backup 12.0).
My question is, why did none of the diagnostics detect a problem with at least one drive? Where did half the space go? And what to do now: replace the defective drive, if I can yank it from the unit and identify which one it is? I assume I will need to restore the system and reformat. Maybe I should just reformat anyway and see if the space comes back?
Also, are any of my assumptions incorrect?
Thanks for your help with this,

Log into the system using SSH and execute the following commands:

cat /proc/mdstat
df -h

…and post the results.

Hey Tony+++,
Thanks very much for your help. I hope I performed the SSH session correctly. The results are below.
Oddly, the drive accepted backups overnight from two machines and now reports remaining space as 5.87GB, which is about what it should be. The backup op was a few hours longer than usual, and I’m not certain why that was. Perhaps some startup ops were active?
Again, thanks very much.

root@WDMyCloudMirror root # cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md1 : active raid0 sda2[0] sdb2[1]
7805644288 blocks super 1.0 256k chunks

md0 : active raid1 sdb1[1] sda1[0]
2097088 blocks [2/2] [UU]
bitmap: 0/16 pages [0KB], 8KB chunk

unused devices:
root@WDMyCloudMirror root # df -h
Filesystem Size Used Available Use% Mounted on
%root% 54.2M 30.2M 21.3M 59% /
/dev/ram0 54.2M 30.2M 21.3M 59% /
mdev 248.4M 32.0K 248.4M 0% /dev
ubi0:config 12.2M 660.0K 10.9M 6% /usr/local/config
/dev/loop0 93.9M 93.9M 0 100% /usr/local/modules
tmpfs 1.0M 0 1.0M 0% /mnt
tmpfs 40.0M 2.7M 37.3M 7% /var/log
tmpfs 100.0M 3.0M 97.0M 3% /tmp
/dev/sda4 944.9M 19.5M 925.4M 2% /mnt/HD_a4
/dev/sdb4 944.9M 18.5M 926.4M 2% /mnt/HD_b4
/dev/md1 7.2T 1.9T 5.3T 26% /mnt/HD/HD_a2
root@WDMyCloudMirror root #

Yeah, that all looks healthy. I guess it just needed time to “catch up.”

OK, TonyPh12345!
Thanks very much for you looking at this for me, and introducing me to SSH.
Love these digital terms, like “catch up,” and “startup ops” …! They are so reassuring.