Airport Extreme won't show My Book Live

Just purchased a MBL and connected it to my Airport Extreme via the enthernet port.  Finder in my Mac Mini can’t see the MBL via wireless but can see it if I also connect my mac mini via it’s ethernet port to my Airport Extreme.  WD support was not very helpful (and it was clear the guy I talked to didn’t know anything but only reading from a knowledge base) telling me it’s a UDP problem and to call Apple becaue WD can’t help me!  What’s that all about?!  This product is designed for Mac’s and Airport Extreme is a common router used in home mac networks.  For WD not to have a solution on how the My Book Live can be accessed via the Airport Extreme is shocking!  If you can’t see the MBL via Airport Extreme then I question how Mac compatible the MBL really is.  I currently rank WD technical support at 1 out of 5.  Shocking.

Do any of you know how to modify the Airport Extreme settings to allow me to see the MBL?


Which version of Airport Extreme do you have? What is the firmware version of the Airport Extreme?

What is the firmware version of the MyBookLive?

Have you tried to access it without finder - i.e., going via the ipaddress of the MyBookLive on your network,

through a browser?


Are your WiFi and cable network on the same IP-Range?

Since you can split them, you may want to check this.

Further more, I do understand your rant, but maybe none of the both companies are the culprits?

Sometimes even Apple products need to be configured propperly :wink:

I have a MBL on an Apple Extreme working with no problem via WiFi and cable.

Maybe we should parse your configuration?


Thanks for your feedback.  Here are my answers:

  1. Type of AE?  Not sure how these are classified but I bought it 2007ish and it was the N wireless protocol.

  2. Firmware version of AE?  7.6

  3. Firmware version of MBL?  02.10.09-124 

  4. Have I tried to access MBL via http://?  Yes, although I only get a blank page in Safari I also tried Go Connect Server through the Finder menu and interestingly it seems to communicate with the MBL and it asks me for my password but when I put in the password (or go in as a guest) I get an error message saying the “There was a problem connecting to the server .  Check server name or IP address and try again.  If you continue to have problems, contact your system administrator.”  So it doesn’t let me go any further than entering my password.

A couple furthers bits of info that may help:  

  1. looking in the sys log for the AE it appears that the MBL is communicating to the AE.  I get the message  Severity 5: SMB/CIFS login OK from O%@<IP address corressponding to MBL.

  2. When I use the Connect Server function in Finder and then drop down the list of recent servers it list MBL as two different options, (a) an option for MBL (name) which when clicked has an afp://MyBookLive._afpovertcp._tcp.local and (b) an option for the IP address which has a corresspoing entry of http://.

Am I right that some communication is getting through to the MBL attached to my AE?  What is the AE doing to block the rest of the communciation?

Thanks for your help!

Answers to Rockstar’s questions:

  1. Are your WiFi and cable network on the same IP-Range?  Not sure what that means but all my devices including my wireless router all start with the same IP address numbers and only change the final two numbers.

How did you get your MBL to work on your AE?


Wireless router & AE?

I just plugged mine in and it worked - go to the app store and get lanscan (for free) and scan your network.

Sounds like a network issue.

-> Severity 5: SMB/CIFS ??? AE and MBL wont communicate via SMB AFAIK.

any Windoze CPU’s around???