Aftermarket firmware warning loop


#1

I finally decided to do something about my WDTVLV+ latest firmware not being able to play VOB files over the network without constant video stuttering and loss of sound.  This was never a problem when the original firmware (store bought) was installed.  Then I took the first automated firmware update bait.  The functioned with well with increasing interner content, but the VOB files just did not play well.  I tried to just play the VIDEO_TS folder as other users suggested, but about 50% of movies played with no sound. 

So, I tried to apply the v1.03.49_B GPL version of the firmware.  Not good! Now my box has turned into a looping brick with the following message:

Warning! This media player was modified aftermarket and is running unoffical firmware that is not support by Western digital.

Funny, that the GPL was released by WD, but the message puts it into a hacker category. 

If anyone has any suggestion short of buying a new media player (not sure what brand yet), I greatly appreciate it.  Thank you.


#2

Huh?? Where did you download THAT from? WD provides GPL SOURCE code, but not compiled binaries called GPL…


#3

That is what I downloaded.  The GPL source code from the WD support site.  I, too , did not think that it was compiled.  There is a [build] folder when you untar the downloaded file.  In the [build] folder, there are the three files: wdtvlive2.bin, wdtvlive2.fff, wdtvlive2.ver.

Those are the files that I fed to my device using a USB stick.


#4

The GPL “Build” files are not complete.    

If you notice, the wdtvlive2.fff file is pretty small…  In the 1.04.17 GPL, it’s only 1 Kilobyte.

The fff file contains all the PROPRIETARY CODE, as well as the Linux Kernel that boots the box and operates the rest of the code.   The binary that comes with the official package is almost 7 Megabytes.

The GPL “Binaries” are *ONLY* compiled from the GPL-licensed source code.   The proprietary assets are not present, nor does the GPL license require them to be.

The license only requires WD to provide the source code and compilation instructions for the items covered under the GPL; the user is left to his own to create his own substitute for the proprietary code.


#5

I appreciate your answer TonyPh12345.  Regardless of what is or is not included in the GPL Code, this is the state where my box is at - Looping brick.  I would appreciate any answers regarding how to get out of this mess.  This n00b has received enough bashing from the rest of his own family about screwing the box up.


#6

View the following post from a user who was stuck in a loop with the official firmware:

http://community.wdc.com/t5/Firmware/New-Release-Firmware-Version-1-04-17-B-for-WD-TV-Live-Plus-12-30/m-p/115162#M8853

You can obtain the proper, official firmwares from this page:

http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_faqid=5800&p_created=1289519053&p_sid=gikY3-jk&p_accessibility=0&p_redirect=&p_srch=&p_lva=&p_sp=cF9zcmNoPSZwX3NvcnRfYnk9JnBfZ3JpZHNvcnQ9JnBfcm93X2NudD0xMTksMTE5JnBfcHJvZHM9JnBfY2F0cz0mcF9wdj0yLjMzMyZwX2N2PSZwX3NlYXJjaF90eXBlPWFuc3dlcnMuc2VhcmNoX2ZubCZwX3BhZ2U9MQ!!&p_li=&p_topview=1

-edit-

I see that Bill just posted a link to a KB article on firmware update loops.  Check it out here:

http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_faqid=6543

I know these aren’t exactly the same issue you’re having but hopefully the solution is the same.  Good luck!  :)