After Windows 10 Update Files Dont Show on Mapped Drive

Ok after I updated Windows 10 a few weeks ago something weird is happening to WD MyCloud

If I open it on the Desktop APP it shows all the files there as normal as one can see here:

When I go and open the same directory on the mapped drive all the files are not present as you can see here:

And to make things more weird when you look under this PC the system says that the size of the WD MyCloud is the exact same of the C drive as you can see here:

(See first reply as the system allows just 2 images per post)

Does somebody knows why this happens and how to fix it once and for all?

I already tried all the solutions posted on the

“Compilation of Windows 10 Methods, Steps and Solutions Thread”

and it does not solve my issue. My WIndows 10 is Up to Date and this started happening a few weeks ago after a wiindows update.

Any help you guys can provide would be greatly apreciated.

Here is the other image:

A few things to try:

  1. Hit refresh in Windows File Explorer while connected to the My Cloud to see if Windows Explorer will rescan/refresh the file listing.
  2. Remove the mapped drive, reboot the computer, then remap the drive and see if all folders show.
  3. Try accessing the My Cloud using it’s IP Address rather than name to see if that has any effect on what is or is not shown in Windows File Explorer.

Thanks a lot Bennor

  1. Hit refresh in Windows File Explorer while connected to the My Cloud to see if Windows Explorer will rescan/refresh the file listing.

Already Tried this and it does not work

  1. Remove the mapped drive, reboot the computer, then remap the drive and see if all folders show.

Usually this works after doing it 3 or 4 times. Is something I need to do every morning when I boot up my PC is do this 3 or 4 times and then the thing works fine but it should not be like that. I should be able to get access 100% of the time every time without having to be maping all over and rebooting my PC

  1. Try accessing the My Cloud using it’s IP Address rather than name to see if that has any effect on what is or is not shown in Windows File Explorer.

How do I do this?

I can access my WD Admin panel on this IP 192.168.11.118 but have never being able to access actual files via that IP

If you can access the dashboard via 192.168.11.118 with an internet browser, on Windows Explorer (NOT IE) type:
\\192.168.11.118

https://www.google.com/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=windows%20explorer%20vs%20internet%20explorer

ok perfect I mapped this using IP now so I have it both ways I will keep an eye on it to see if the issue happens again.

Thanks a lot for your guys help.