After upgrade to OS5 MySQL database for WordPress lost?

I must be doing something but I cannot find the WordPress mysqldatabase that I had before migrating to OS5.

I had a workding WordPress with phpMyAdmin installation in OS3.

I have just now upgrade OS3 to OS5. I understood that the apps would be uninstalled but I understood from the messages that the data and the configurations would be kept.

After the firmware upgrade, I reinstalled WordPress and phpMyAdmin but when I launch WordPress, it takes me through the configuration Wizard and tries to create a new database.

If I look fromm phpMyAdmin, I cannot see the wordpress dabtase that I used to have.

The only thing left is a symlink located on “/mnt/HD_a4/.@database@” called WordPress which points to a non-existing location:
/mnt/HD/HD_a2/Nas_Prog/WordPress/database/worpress

I had a look at this article and it does not say anything about this situation.
https://support-en.wd.com/app/answers/detail/a_id/29396#thirdparty

Am I right in assuming that when the upgrade too OS5 is applied the SQL databases are deleted? That would be surprising. I must have done something wrong.

Thanks!

Daniel

check with your ISP

Ok, I could reproduce the same behaviour in a second PR4100.

This is how it happens:

  1. Install WordPress and PHPMyAdmin on OS3.
    2 Create a database called “WordPress” from phpMyAdmin (requirement for configuring WordPress)
  2. Configure WordPress.
  3. In phpMyAdmin you can see that the database WordPress exists.
  4. Run the upgrade to OS5.

Expected result: the: WordPress database still exists and is visible from phpMyAdmin.
Actual result: the WordPress database is not visible from mySQL.

I think this should be mentioned in the upgrade documentation. The notes and instructions suggest that no data will be lost.but actually it seems that the the MySQL databases are wiped.

@Vegan Thanks for your comment but I am not sure what role my ISP provider plays. We are talking about local installations of MySQL and WordPress on a NAS. I am accessing the NAS via the local network, not externally.

All the best,

Daniel
Daniel

I run my own website on an old Lenovo X230 but I o not use PHPMyAdmin etc. I use the ssh access to the console and a browser to run WP, I run Ubuntu 20.04 on the old laptop.

I created a database with the command line using MySQL and WP found it and created tables with the standard _wp prefix and proceeded to load

with ssh access a certificate was trivial as the setup was well known

Thanks, @Vegan but I don’t think this applies to my situation. I am referring to a very specific situation: with the upgrade from OS3 to OS5 in a My Cloud Device (PR4100) the existing data in the MySQL database is lost, which is not what should happen in this situation without any warning to the users.

Of course, I could create new database and and reinstall WordPress on the PR4100 but the data I had before the upgrade in the WordPress database in the MySQL server seems to be lost. :frowning: Luckily, it was not that much data but it was scary to see that it was deleted by the upgrade.

Daniel

I backup my database all the the time to a USB sick along with a copy of the site.

Only reason for the backup is in case the laptop bites the dust, it is 10 years old