After Update To 2.2.8 FTP not working, showing 500 OOPS: child died

After I upgrades to 2.2.8 everything worked fine except the FTP server, i havent changed any of the settings but now this happens:

Status:    Connecting to 192.168.0.100:21…
Status:    Connection established, waiting for welcome message…
Response:    220 vsFTPd 2.0.4+ (ext.3) ready…
Command:    USER malcolm
Response:    331 Please specify the password.
Command:    PASS ********
Response:    230 Login successful.
Command:    OPTS UTF8 ON
Response:    200 UTF8 option is On.
Status:    Connected
Status:    Retrieving directory listing…
Command:    PWD
Response:    257 “/”
Command:    TYPE I
Response:    200 Switching to Binary mode.
Command:    PASV
Response:    500 OOPS: child died
Command:    PORT 192,168,0,101,201,122
Error:    Connection closed by server
Error:    Failed to retrieve directory listing

I’m using Filezilla 3.3.2.1 and I haven’t changed any settings and it was working before the upgrade, can anyone help please?

Wibblefish,

What OS are you using to access the Sharespace after the upgrade? After the upgrade, i was lockout from my data, As i am using XP, i was advised by WDC support to try Windows 7 or Vista. I wonder if OS matters?

-Ryan

I’m using Windows 7 professional 32 bit and Windows XP Home (both using filezilla FTP client) and get the same results with ether OS. Western Digital did something to the FTP Server that hade it throw out the 500 OOPS: child died error, as you can see in the log it can connect to the server but can’t retrieve the directory listing

Thanks, What Service Packs you are on with Windows XP Home?

-Ryan

SP3

I am getting the same error message after updating the firmware last night. I am using XP SP3 and OS 10.6.4. I can remote into the settings over port 80 so I know it’s not my router settings. Can anyone help?

Thanks,

Odessy_97

I also experienced the same issue. I found a workaround, try changing the Filezilla Transfer mode settings from Default or Passive to Active. With that change, I was able to browse my sharespace via ftp without getting “Child Died”. I doubt this is supposed to be this way, since I never had this problem before the recent update.