After Safe Removal, "Delayed Write Failed" With My Book over Firewire connection to Win XP


#1

Title says it all -

After a “safe removal” using Win XP, I unplug the firewire connection, and then, several seconds later, I get a “Delayed Write Error”.

This can happen even after doing no writes at all to the drive,such as:

A) Booting up the Laptop with the drive connected

B) Copy over a movie to the laptop hard disc from the My Book

C) Safely remove the MyBook

D) Unplug firewire cable, as notebook is about to be carried elsewhere

E) Get “Delayed Write Failed” error from Windows XP

How can we debug this problem?  Event Viewer has no log of the problem.


#2

Hey,  I am also getting this same error with my MyBook Elite 1TB external drive.  I have upgraded the software and the firmware and still I get this “delayed write failed blah blah blah”.  The drive worked just fine for about 2 months and then blam now Windows loses connectivity to it everyday.  I am not impressed with having to always reboot this thing to get it back.