After power outage MBL file transfer is 2.2k and always fails

We had a power outage a few days ago and now I can’t write any files to my book live 2T no matter how small. It starts and tries but is at a rate of 2k and then fails after 10 or 15 minute of trying. I have always had trouble with this drive but thought it was because I was using XP. Now I am using Windows 7 (64) and it was working prior to the power outage (outage lasted 30 minutes so not a spike). When power came back on it took a long time before I could access the drive other than through Twonky. It said it was updating the database but took over an hour. Once I could access it with my computer and remotely via phone but can’t write files too it. What can I do to repair this drive? What maintenance is available?

Thank you.


Have you tried resetting the unit? If not, please try that.

I have reset it multiple times. The unit is accessible and I can read files but I can’t write files over a few kb in length. If it is more than about 50k it will time out and fail. Looking at the system report all looks good except it says the log files are full. I don’t see how to delete the logs. Running full maintenance scan reports no problems. In short, I can copy very short files but not medium or long files. I just tried to copy a 900kb file and it failed but an 18kb file copied ok.

Is there no way for me to see what it is doing or did? I find it very interesting that I can write tiny files to it but can’t read even small files. Last night I could write 18kb files but when I tried to save a 28MB file it got to 13.9mb and hung for 10 minutes then said it could not write the file. Are there no utilities I can run to see what is happening and/or why?

Thank you.

This is a guess based on total ignorance, but I’d bet there is a way to view an error log using SSH.