After fox_exe's chroot installation, how can I configure transmission download folder's permission?


I have My cloud Gen1 and I executed
I answered ‘y’ when the prompt asking about install transmission in chroot script.

However I don’t know how to configure the permission download directory of transmission-daemon.
(I changed download location in /Datashare/debian/var/lib/transmission/info/.config/setttings.json)

What I am confusing is the UID and GID when I use chroot.
What UID and GID should be used for setting permission the download directory(ex. /shares/Public/)
I tried to use the PID and GID number of transmission-daemon when I used top command but I saw permission denied log at /var/log/daemon.log.



I have never tried this. There are a lot of experienced user that can share some ideas with us. Let’s wait and see if any of them can scheme on this issue.

Hello Hamlet,

Thanks for your reply and I found the solution by myself.

There was a explanation in the install document.
/DataVolume/shares mount to /mnt/ (actually it is /DataVolume/debian/mnt) and
I configure the download directory to /mnt/xxxx.


Thank you for taking the time to share the solution to your issue.
This may help other users in the future.