After changing router WD mycloud mirror is not accessible anymore - IP chaos?

Hi community,
I spent my last 24 hrs in trying to figure out the right post to solve my problem. So apologies ahead. Maybe it is because I am German…

So what happened?
I used WD MyCloud mirror Gen1 with a Telekom Speedport 724W. A very limited router. In the WD dashboard I assigned a fix IP address. I am in MAC environment,
Then I replaced the route to a Fritz!Box 7490. No surprise the router allocated a new IP address and the mess started.
Dashboard access - No, etc.
I checked the IP address & tried ping to new IP address - failed. This was puzzling me completely. Does the browser block the ping?
Rebooted server as I thought the IP needs to be confirmed after restart. No change.
IP address was set to fix and variable without effect.
I still see it in the browser list but no other access worked. I am lost and desperate.
May I kindly ask for help of some other brains. I think in circles now.
(edit) - I switched the firwall off just to test if it is blocking - no success.

What is the IP address range for the old and new routers?

For example, if the old router is using 192.168.0.x/24 and the new one 192.168.1.x/24 then they will be basically separate networks and your MCM won’t appear on the new one if it has been assigned a static IP address on the old one.

If you still have the old router you could temporarily reconnect it, then set the MCM to a DHCP IP address and then put the new router back and let it assign the MCM IP address (and then use that to reset a new static one in the new domain if you wish).

Another option could be to connect the MCM directly to a computer with an Ethernet cable and give the computer a static IP address on the same range as the one the MCM is set to. They should then be visible to one another.

Or if all else fails, you can do a 40s reset, which will set the IP address back to DHCP but will also reset other things (although won’t lose data). See the link below for details of what gets reset and how to do it:

1 Like

Thanks Darren,
great initial thoughts.
IP range old: 192.168.2.x - assigned 222
new: 192.168.178.x - given 33
I thought about the 40sec reset but was not sure about potential data loss.

Then I had another idea: I set the IP address range of the new router to the old range and this fetched the server.
You are totally right and it is fully logic that the static server IP falls so to say outside the network. The only thing confusing me was that the new router listed the device as if everything was fine. So the failed ping confused me. How can a router list a device as functioning and identifiable etc… and a ping does not go through. Crazy.
I have no clue if this helps someone else: But if you have the same problems:

  1. Change static IP before you move. You are all set :slight_smile: But then you would not come here :-))
  2. Create a work environment of old IP range
    a. Attached directly to PC
    b. embed in old IP range network.
  3. Reassign IP address to dynamic or within new IP range.
  4. Restart in new environment.
  5. Smile on the face

Does this sound like a correct description? I hope so.
Let’s see if the new range works smooth or causes other problems. But for the time being I am fine. Thanks

Yes, that sounds fine (it’s basically the second option I listed).

The other habit to get into is putting static IP addressed devices into DHCP mode temporarily before you swap routers, or to make sure that the new router uses the same address range as the old one.

The other option is to not set static IP addresses on the device, but do it at the router end. So it’s still DHCP, but for whatever devices you set the router (or whatever is fulfilling that role) always gives it the same address. Most modern routers have this capability, and it can save a lot of hassle.

To answer your question, most routers use a subnet mask Basically that means that anything not on the same range (192.168.0.x, 192.168.1.x, 10.10.10.x or whatever) gets masked off and is not accessible. You can change that netmask to allow wider access, but it’s not the simplest thing to do and can occasionally cause other issues.

Anyway glad to hear things are up and running again.

Great answer, Darren! The 4 second reset got my MyCloud back on the network.