After changing house, MyCloud isn't working

Hello everyone,

I bought my WD Mycloud 2to in South Africa. I set it up with an IP address from there.
Since then, I’m back in France, but I can’t access the device.

I plugged it to my router, I can see the device in the Finder, but impossible to access …
I even tried to plug it directly to my Mac using ethernet wire. Still the same.

Using Safari, and writing its IP address, still the same, and writing ITSNAME.local, same …

I even tried with the tools WD MyCloud Setup and WD Access
These softs can’t see it, even though my Mac can see it (but can’t access it)

I feel it’s something about the IP address. I might have to change it, but I have no idea how to do

Do you have an idea, how to access it again ?

Thank you

Following this… I plan to change my IP too…

Are there any changes in the indicator light on the front of the unit? Is it red, etc?

You might also consider performing a 40 second reset. With the unit powered off, insert a paperclip or other small pointy object into the small reset hole on the back of the unit, and with the small button inside held down, attach the power and wait approximately 40 seconds. This will reset the device to factory defaults in terms of using DHCP, and password use. That should let you set the device up again at your new location, if it should come down to it.

Okay. Thanks for the answer. Will try this
But are you sure it’s not gonna delete all my data ???

User data is not affected when performing a 40 second reset. See the following WD Knowledgebase article that explains what is reset to default when performing a 4 second and 40 second reset.

And you should be running a Backup / Safepoint of the My Cloud if the data being stored on it is irreplaceable. The My Cloud User Manual and other information that explain how to perform a backup of the My Cloud can be found at the following WD Support site.

Ok thanks. I got backup already.
Last question : how to choose the IP address then ?

Your modem/router’s DHCP server will assign a new address to the MyCloud. Let it do its thing…

You can enable DHCP in MyCloud and MAC bind in the router to assign it a fixed address everytime.

Great. Thanks for all your answers.
I just did the 4sec reset. It was enough, just to enable the dhcp.

Now it works. And the router gave a dynamic IP to the Cloud.
I might have it a static one later. What do you advice me ? What is the best ? Static or dynamic ?

I leave DHCP enabled on the MyCloud, and then use the router to set an infinite timeout, which means that the router will keep using the address it has assigned.

How do you do that ? Is it in the router’s parameters ?