After 20-30 minutes of playing ANY video file, player refuses to respond in proper manner

After playing video for some time if I press pause or rewind, player fails to resume, message pops up that it cannot play file - RIDDICULUOS as  it is already playing! Right? And if I press stop or Home buttons it does what requested but video still plays in background! And it won’t stop untill I restart the player! HORRIBLE!!!

Restarted on every way possible, newest firmware, previous firmware… SAME!

Is it faulty unit? Maybe memory chips are bad?

Is there any solution?

Hi Luka3rd,

I have this exact same issue:

I have tried countless factory resets, fw updates and even tried on a wired connection.

All file formats behave exactly the same with the exception of a direct DVD copy (.VOB)

These play perfectly.

My wife & kids don’t use this product anymore and have resorted to playinng all discs on the playstation - what a surprise!



Hello  slip.cougan!

I just read your post… Yup, it’s the identical problem.

I called the service rep and he said I should play over USB to check if it has the same problem, well - it does. So, he told me to bring it in for check, and that they will replace if faulty or return me the money, we’ll see.

However, even if it did play the files over USB I would still try to return it as that function is not for what I have bought it.

I still hope that just some part of firmware which is system part is corrupted, or something like that, and that they will make it work since I like the player for its nice menus and very good subtitles control (I am non English native)…

I will post the outcome of service… probably not before the 10th of January.

Well, answers have arrived finaly!

I wrote to the official WD supprt, with the same explanation of the problem and they have answered:

“…Since troubleshooting hasn’t worked on this unit we recommend to replace it…” They have everything explained, how to send the unit back to them for free replacement…

However, I live in one terrible country from which it is not allowed to businesses in US by US Goverment to do the job with us, so I took the player to local service rep and after series of tests they’ve done - conclusion is the same - faulty unit. Since they currently don’t have new ones, I took the money back.

(So, I am thinking right now to get the most expensice but best solution, iMac mini + XBMC… I’ll see…)

Hope this helps someone.

luka3rd wrote:> (So, I am thinking right now to get the most expensice but best solution, iMac mini + XBMC… I’ll see…)



Great decision. :slight_smile: