AFP/Time Machine with OS X Lion and newest update

Another problem with the update. Forgive me if this has been addressed elsewhere. I have been able to find similar problems, but not this one.

I updated the firmware on my MBWEII and everything seems to be working exactly like the old firmware, but I CAN see the device as a time machine disc named “WD_Backup”.

But when trying to connect and backup my machine via time machine, I receive the error “The network backup disk does not support the required AFP features.”

If I log into my MBEWII, go to Advanced >  Network > Services, the check box for AFP > Service, is indeed checked.

Am I missing something here?

I am having the same issue.  I updated to 01.02.10 solely for purposes of getting Time Machine to work with Lion, but even though the update applied, I still get the AFP error just like I did before updating.  I have tried disabling and re-enabling AFP, but that didn’t do anything. 

Edited to add: I can see both “MyBookWorld” and “MyBookWorld-Backup” in the finder, and while I can write manually to the “MyBookWorld” drive, I am completely unable to access “MyBookWorld-Backup.”  I get a “Connection Failed” in finder, and then the AFP error when using Time Machine.

What spdp7 said? Same for me.

What on earth is going on with this thing? Is it now a paperweight?