Advice to WD to improve RMA process (mods/admins plz read)

Hi @ITsalezguy - All I can do is pass along the information to our team (I don’t work in that group). They are usually pretty fast at getting the model numbers added when this occurs. Have you tried to RMA those model numbers and got the $0 price on them? If so, did you use the same email address to register the drive that you registered on the community with? If not, could you provide me the email address you used via private message - this will help them investigate.

Thanks, I appreciate it. Email address doesn’t matter, I’ve used several, and I can confirm that several of those models that the previous poster listed still come up as 0 value. Anyone can verify that by creating an account on the warranty site,registering valid serial numbers and beginning the advance rma process. Try the account below. I registered the serial number from one of our 6 TB purple drives in the office computer, and if you try to advance rma it, you’ll see it displays a value of 0, just like the photos in this thread.

[Removed for Security]

PS - This forum doesn’t allow me to send private messages, so I had no choice but to post that account publicly. Might be hacked by the time you read this, but it’s just for demonstration purposes so not really a concern.

Thanks for the updated info and for letting me know that some of the previous models had not yet been resolved. I’ll make an inquiry about it tomorrow morning and see if there is anything I can do to help expedite the process.

EDIT - What does it tell you when you try to PM? The forum allows PMs (I use them all the time) but has some restrictions on new accounts using the feature to help prevent abuse.

Great, I appreciate your efforts. There simply isn’t any option to send pm’s, probably just because I’m a new user.

Not surprisingly, the new 12TB drives(model WD121VRYZ) are also un-RMA-able because of this same issue. Again, I don’t need your help, your tech people need your help. They have serial numbers for all the models and can create an account in less than a minute to replicate the issue, just like ITSalezguy did. They’ve fixed the problem for the older models, so tell them to get off their lazy ªsses and fix this [AGAIN].

Like several other people in this thread have mentioned, dictating address/product/contact/payment information over the phone to a guy on another continent takes much longer than typing it into the website. This problem is hindering the productivity of your retailers.

A post was split to a new topic: Why WD RMA has been sent to an outsourced Indian call centre?

Yes, model WD121KRYZ can be added to the growing list of products that can’t be advanced RMA’d. Judging from the length of this continuing forum thread, it doesn’t look like they have any intention of fixing the problem.

Hi @bobdix86 - As I tried to explain to @SwannyRiver above, the issue is not specific to the model of these drives. We need serial numbers in order to reproduce the issue.

To anyone who comes across this thread in the future: Please be sure to register your drive under the same email address you used to register on the community. This will allow us to look up your account without having to private message you for an email address and/or a serial number.

Sorry but that’s just not true, and it sounds like a cop out.

First of all, when they fixed this problem earlier this year, it was not serial number specific. Simply view the posts above from around February to see that the user Akinori only had to provide one serial number for the programmers to deduce the problem. Suddenly, ALL models were able to be advance rma’d.

Secondly, I could provide literally hundreds of serial numbers from any of the models mentioned in the last few months-every single one will have this problem. I seriously doubt that my distributor alone just happened to receive all the units that can’t be advanced rma’d. The one thing they all have in common is that they’re new models released AFTER February, when they first fixed this problem.

Though I’m very wary of incompetent tech people permanently voiding my warranties, I will try - time permitting - to provide Great_Scott with numerous serial numbers so we can try and fix this problem for the second time.

Agreed. Wasn’t and isn’t a serial number problem, it’s a model number problem as per my findings. And yes, your tech people are so workshy they can’t even be bothered to get their own serial numbers to fix this. Of the millions available, not a single one could be acquired, so we have to sacrifice ours-hilarious.

I’ve sent an example to GreatScott, and hopefully SwannyRiver has done the same. Not much else we can do except wait(perpetually it looks like) for WD IT people to fix this.

Hello again. Yes, this problem was fixed last year when I provided only one or two serial numbers to Bill_S. After this, all models were working. But now the problem has returned!. I have provided one dozen different model numbers with serial numbers to Great_Scott in a private message. All of these models are new internal hard drives only. This will prove that it is the same problem as before. This should be solved easily the same as last year.

Thanks for providing the information @Akinori_Hishiya - I have passed it on to the development team to investigate. This appears to be a different issue than the one we resolved last year (although the symptoms are identical) and isn’t as simple to resolve - the information you provided is extremely valuable in our efforts to do so.

This is also affecting WDBMMA0040HNC. A value of $0 is preventing an advance replacement.

/cc @Bill_S @Great_Scottt

When is WD going to wake up? So many models cannot be submitted for RMA!

WDBCKA0080HBK
8TB Easystore

WD80PURZ
WD60PURZ
8TB & 6TB Purple. (newer gen)

WD100EFAX
10TB Red

WD8003FRYZ
8TB Gold (newer gen)

WD8001FZWX
8TB Black

12TB My Book Duo Model WDBFBE0120JBK

and more.

It’s been months and you never assign a value to any of these! It says $0 on the payment form, so the RMA can’t be submitted!

Finally CVC with 0 beginning 3 digit code now works!

How many more months until you have assigned dollar amounts to all of your models!? Maybe by 2020?

Hello. Since last October you said you were working to fix this.

However, the OP’s post, and a newer one, have gone unresolved

Isn’t it unprofessional and amateur for WD still to not have assigned a dollar value to such a big model as WD80PURZ (8TB Purple) and WD8003FRYZ (8TB Gold)?

How can WD sell these products, but not allow RMA’s for them, months later?

This post was flagged by the community and is temporarily hidden.

Hey Great Scott, how come months later, models still cannot be submitted for RMA? You were supposed to get dollar values assigned…

What logic does WD have to assign a dollar value to 10TB Purple, but not 10TB Red or 12TB Gold?

WD100EFAX is 10TB Red & WD101KFBX 10TB Red Pro and WD121KRYZ is 12 TB Gold. None of those 3 models can be RMA’d

Nor can the new 8TB Purple model wd80purz. only the old model WD80PUZX has a dollar value.

But 10TB Purple does have a value and can be RMA’d.

WD has no rhyme or reason.

We need this fixed! I don’t have room to back up the 20 TB of data on my failing WDBFBE020JBK unit
Because your advanced RMA doesn’t work, now I have to spend 2 weeks uploading to the cloud. FIX THIS ALREADY!WDSiteIsJunk

/cc @Bill_S @Great_Scottt

Nobody cares at WD. They sell hard drives & pretend to allow warranty, but never update the value so it says $0 forever.

WDBCKA0080HBK
8TB Easystore

WD80PURZ
8TB Purple

WD60PURZ
6TB Purple

WD100EFAX
10TB Red

WD8003FRYZ
8TB Gold

WD8001FZWX
8TB Black

12TB My Book Duo Model WDBFBE0120JBK

HERE IS 8TB GOLD WD8003FRYZ SHOWING $0 VALUE SO CANNOT DO RMA

So despite the following thread from months ago with acknowledges from WD employees that they were aware of the situation & would have it fixed: https://community.wd.com/t/advice-to-wd-to-improve-rma-process-mods-admins-plz-read/163795/78

There still is no fix. So many models still cannot be submitted for RMA because the value assigned to that model is $0, so you cannot complete the checkout, such as WD8003FRYZ
zero%20value

Also WD80PURZ , WD60PURZ , WD100EFAX , WDBCKA0080HBK , WD8001FZWX & WDBFBE0120JBK

Best Buy & other stores sell these models, but to WD, these models don’t exist, & they offer you none of the warranty support they claim when you buy them.

So, since the moderators here are incompetent, I thought I’d try opening a support case showing those employees that these models have $0 values assigned to them. I showed them screenshots and all. And this is the incompetent response I received:

image

No, it is not my browser, & what? Complete incoherence from WD.

So sad.