Advice on data recovery

I have a MBL which has been running for the past few years in RAID1 without any major issues. However, within a couple of days the network connection to the NAS became unstable and then I could not connect to it. Now I hope that I can recover the data on the disks.


In order to try to recover the data I have followed the first part of the instruction described here:


‘Disk Internals Linux Reader’ and ‘R-Linux’ could not recognize the file system. Therefore, I tried Hiren’s Boot CD, but it gave me the error message: unknown filesystem type ‘linux_raid_member’.


Then I tried the ‘Ubuntu Desktop CD’ as described here:

But I received this error message:

‘wrong fs type, bad option, bad superblock or /dev/sdb4,  missing codepage or helper program, or other error’.


I have spent a lot of time trying the above and searching the web for other things I can try, but I don’t seem any closer to a solution than when I started.


All input on how to proceed is greatly appreciated.




Sorry to hear you cannot access your files. Since you had a RAID 1 setup, have you verified with both disks if you get the error messages? If the problem continues, I would try to contact support directly for assistance.