Advice on accessing my music library synched on my NAS via BOSE Sountouch 20

Can anyone offer advice on how I can play music stored in my music library on my NAS through my BOSE Soundtouch 20 system please? I have added the music library to my BOSE app but it appears to have nothing in it. I have synched the original library from my laptop to the My cloud NAS. I’m not an IT expert but I have an above average understanding but I have found all of the BOSE and WD help has not helped me to achieve my goal.

If you read the User Manual for the BOSE SoundTouch 20 (, page 19, you’ll see that it supports “AirPlay” to stream media over WiFi.

It appears that one uses the “AirPlay” app/software on the device/computer to send content to the SoundTouch rather than using the SoundTouch to find media severs on the local network. If this is the case then one cannot stream media direct from the My Cloud to the SoundTouch, instead one will have to use an “AirPlay” app or software on their mobile device/computer to stream the media from the My Cloud to the SoundTouch.

Yes, it looks like it is a dumb AirPlay digital media renderer (DMR), relying on a separate digital media controller (DMC) to control what is streamed to it. The Soundtouch itself appears to have no DMC function.

Thank you for the replies, WD support sent me an e-mail and their instructions have uncovered one missing setting on the shared drive. Problem solved.

Share your solution so others can find it and also mark it as closed.

Please post your solution incase others experience the same with a BOSE product.

I’m guessing it was enabling streaming on the share: the known issue of inconsistent default settings.

Q. Why doesn’t Twonky find my media?

Always fun when someone reports getting a solution from WD and neglects to share the info. Happened to me recently, and I asked what the solution was for a drive issue that WD “solved” and the answer was they told me to format it and now I can access it again. Gee, I could have given that solution, but was trying to avoid deleting all data. Well, whatever, the person seemed happy with the “solution”…