Can Forum members please reply with details of ADSL2 Router/Modems (cable connection - no fibre here), that DO work with MyCloud Home drives.

I have tried several makes/models of ADSL Router/Modems. All but one (now out of production) do NOT work with the Home device. On those that do not work UPNP identifies the drive OK, but the blue light continues to flash, so it never connects to the Internet externally (even after hours of connection).

The one I have that works is an Archer D5 (TP-LINK 1200 - Annexe A). The ‘HOME’ drive connects to this without any problems. I have tried newer Netgear and TP-LINK devices, but with no success.

I might add, this is NOT operator error or ignorance on my part. For example the latest TP-LINK VR900 I tried yesterday has much the same User interface as the AC1200 model I have that works. All parameters were set the same. All running the latest Firmware. The VR900 identified the HOME drive in UPNP, but it never connects externally to the NET. Same problem with a new Netgear Nighthalk 7000 I tried a few weeks ago.

I have spent MANY hours trying different settings in desperation really, despite knowing the settings that work correctly with the AC1200.

Sooner or later my current AC1200 will ‘die’ no doubt, and as they are no longer made, I really need some information from people who know of Router/Modems they KNOW work OK with the drive. Being able to connect to the HOME drive is important to me.

Ideally a Dual Band version (2.4 GHZ and 5 GHZ WiFi), with two USB ports, but knowing of any that work would be good.


Netgear Nighthawk 7000 works fine for me. I have My Cloud Home Duo, PR4100 all in UPnP port forward mode, but I’m located is Southern California on Cox High Speed Internet.

Thanks ‘socallinux’. Looks like you and I are the ONLY people with Routers that work with the Drive? Perhaps people do not want to help/share their information/knowledge (sigh).
Still ‘hoping’ for more replies.

Those other routers should work.
The only thing I can think of are:

  • UPnP not turned on, not supported or not working and even then the Proxy Relay connections should work
  • Router firewall filtering or blocking TCP/IP traffic or ports
  • Something DNS.local related on the router not allowing local lookup queries
  • external IP changing and MCH servers not getting the updates, but then all routers should not work

Thanks for the reply.

WD have a list of Routers that do not work, for various stated reasons.

As I mentioned my TP-Link AC1200 (Archer D5) has no problems. Interestingly the list above includes a different TP-Link device.

The last one I tried was the TP-LINK VR900, with no luck.

UPNP was ‘ON’ and it discovered the Drive (shown in settings), but it never connected externally so its light kept flashing.

Router Firewall was turned off.

DNS settings were those that work with the AC1200.

As you say, it cannot be the external IP changing.

Even setting the Drive as the DMZ device made no difference, ensuring all Ports were available to it.

My main concern was that if and when the AC1200 ‘died’ I needed to know of some other Router/Modems that worked with the Drive, since experiencing problems with others I have tried.

Since it is out of production, that was a problem, but I found a firm that was selling ‘New’ AC1200’s at a very low price, so I bought a couple as ‘spares’ for the future. As they are all the same model it was a matter of a minute or so to use restore so that all my settings were transferred without having to re-enter anything.

Both work fine, and recognise the WD drives as soon as the internet connects.

Really strange that all three of this model work fine, and other Routers, even from the same Manufacturer do not, despite all settings being the same. All other devices work, I.P. Cameras, an NVR for example. Whatever is causing this it is peculiar to WD MyCloud drives, and not just one. I tested another MyCloud Drive with the same results.