Admin Password login issue

Although I set a password for my admin account, I cannot access the Dashboard using this password. When I click in the Login button, nothing happens, not even a wrong password message appears. Then, I reseted the password (4 seconds reset button) to a non password account, and the Dashboard became accessible.

Once again I tried to set a password, and the same problem occurred: when I click the Login button, nothing happens, not even a wrong password message appears. This time, I reseted the password, using the 40 seconds reset button. Everything became normal again.

I tried for a one last time to set a password after this procedure, but again the same problem occured: when I click the Login button, nothing happens, not even a wrong password message appears.

Does anyone have the same problem as I do?

Any kind of help is welcome.

Best Regards,


It was my Bitdefender firewall…

I am having the same issue, it’s not a firewall or virus protector since after you hit the reset for 4 seconds to clear the admin password, then you can login. I can login as Admin up until I enter a password, then you can’t get login and have to reset again. What’s the deal?

The deal is the min wage WD developers don’t speak English well - not that I’m any better!!

They are unable to tell users that the password must be 16 characters or less AND mix of numbers and alphabets only!!

According to “i” explanation:

cKpE]N)M3(g<e9’U —> Not Good

pYm%u9ppD?mSHhFU —> Good

But when I tried to log in using the 2nd password, it failed and I had to reset my admin password.

Obviously, even though I followed their instruction, I almost peed in my pant fearing it would delete all my data!!

Such a waste of money and time spent on WD solution!! Watching Synology and others on YouTube … just WOW!!

I’ll not insult anyone, but I will say I was also frustrated by this issue. I set the Admin user password twice with a strong password that included punctuation marks and it was accepted, and locked up the account.

It took three or four attempts and a couple resets before finally deducing that special characters were not allowed. Very frustrating and not well documented. I would have thought the first time a password is mentioned, the specs for passwords would be prominently communicated.

WD Community,

Thank you for reporting the issue with the admin password.
We have fixed the password issue and made 2.31.202-Beta available
to the WD Community for admin password fix validation.

WD Staff

I am using an EX2 Ultra, set up about a month ago. I carefully recorded the admin password, and also the account password for my partner. I have just tried to access both accounts, and both passwords have failed.
The admin password comprises numerals, Capital and lowercase letters and symbols. 17 characters in total. It did work initially but now doesn’t. I’ve tried looking up your fix, but the link doesn’t work.

The same problem with my partner’s password, also kept as a written record. same mix of characters, and total 17 characters. Unlike previous people on this thread, I have used both passwords successfully in the past, but not working now.

Can you help?


Further to my last post, I had the bright idea of accessing the database via my iphone. I opened the MyCloud app, but that says device cannot be connected. So I’m shut out of the EX2 altogether. V frustrating.

@JeremyT1 the 4 or 40 second pin reset must be used to reset the admin password on a My Cloud.
fw 2.31.202-beta is not production so ensure that you update to the latest which would be 2.41.116 for OS 3. Ensure that you are using the most recent My Cloud OS 3 mobile app.