Adding USB device

I have a MyCloud Mirror. I have plugged in a EasyStore to the USB port. When I go to the MYCloud Mirror system, it shows the EasyStore but there is no way to see the easyStore in Windows so I can map it and use it to store data.

Normally when you plug a suitable drive into the USB ports, it should appear as a new share automatically (which you can then map a drive to as normal).

Has this not happened for your drive?

It appears as a share (easystore). See the screen shot below, but it does not appear in Windows Explorer so I can access it……

Can you try \\ in Windows Explorer (not Internet Explorer) and show what you see?

I tried and it takes me right to Google Chrome. See the screen shot below of where I typed in the address…

You need to put the \\ in front of it. Otherwise it will do as you say and open the web dashboard.

Literally type \\ in the address bar just below the ribbon.

I did that before and this is what we get:

Two backslashes.

Type exactly what I put above -


That worked. Thank you so much…….One last question. IS there a way to make the easystore be an additional storage capacity for the MyCloud EX2 or the MyCloud Mirror?

No, not in the sense that you mean (seen as internal storage or part of the RAID array).

It can only basically be hosted by the MCM/EX2 as a “pass through” share.