Adding movies to the Library

I’m sure this is a basic operation, but I can’t seem to figure it out.  How do you add one or more movies to My Library after it’s been compiled?

I have “Get Content Info” set to “Auto” and the auto scan schedule set to “During Standby Only.”  I’ve added one movie file to the Library folder, and waited with the SMP in Standby (single press on the Power button, right?)  The movie has not been added My Library at all, much less with Content Info. 

Shouldn’t new movies get added automatically?  Or must I rescan the library folder?

Thanks,

Jack

Anybody?

Works here fine. Just tested it again.

what firmware do you use?

the movei may got a strange/entire wrong title in the media library if you have not named the movie file to the pleasure of WD/tmdb.

I suggest to add the metadata manually with “WDTVHubGen” before adding it to the media library.

I added 1 folder to the share folder of the the medialibrary, just turned the SMP shorly on and off, and the library started to build again. the folder was then showed.

CactusJack wrote:

 

Shouldn’t new movies get added automatically?  Or must I rescan the library folder?

 

Yes, you have to rescan the library folder manually.

I agree, it’s strange that it does not happen automatically (unless you shutdown the unit for a moment and restart it again). I have no idea what rule or trigger starts the automatic scan. I have the same setting (scan only during standby) but if you want to wait for it to start rescanning automatically you will grow a beard … Maybe it’s a bug …?

I played around with this for a while yesterday, and didn’t even see the new movie file listed in the UI.  Went into Standby several times.  Today, I just tried again, and this time the new movie was listed, with no content info.  At least then I could get the info manually, but it would sure be nice if it worked automatically like it’s supposed to.

If I use WDTVHubGen or HubFlow to add the metadata manually, and with the movie file and metadata files in the Library folder, will the WD then pick it up and display the movie in the UI?

The box has the latest firmware, whatever version that is.

Jack

If I use WDTVHubGen or HubFlow to add the metadata manually, and with the movie file and metadata files in the Library folder, will the WD then pick it up and display the movie in the UI?

 Yes thats why i mentioned it…

the SMP prioritise the given jpg/xml over the build-in media libray function (luckily). In fact i do not have a single media file in my collection that have been determined by the WD SMP. Ether its the wrong language (im in germany and it only takes english metadata) or it takes the wrong movie for the metadata.

The problem is that you use the latest firmware. To be able to use this media player carefree, we all should use the firmware from the future… aprox 2 years from now. :confused:

“The problem is that you use the latest firmware. To be able to use this media player carefree, we all should use the firmware from the future… aprox 2 years from now. :/”

Do you have a link to that firmware? 

OK, I’m starting to feel really stupid here.  I added one movie file (an MKV file) to my Library folder.  I got the Content Info using HubFlow, putting those files into my Library folder as well.  When viewing My Library on the WD SMP, the new movie does NOT appear.  When I go to the Files section, the movie file still does NOT appear.  I have to change to folder view, in which the movie DOES appear.  Changing the view back to My Library, the new movie still does NOT appear.

I powered off the WD (holding the Power button for several seconds.)  After powering back on, message said the WD was rescanning my library files.  Even when this completed, my new movie was still NOT in the My Library view. 

I looked for an option to rescan the library, but all I could find was to “Clear Media Library,” which I believe will clear all Content Info and rescan all files in the library.  I really don’t want to clear everything (much of which I had to manually find) just to add one movie to the Library.

So what am I missing here?  Surely there’s an easy, reliable way to simply add one or a few movies to My Library.  Someone please straighten me out here!

Jack