Adding MBL shares or folders to Windows 8 Libraries

I know many people have tried to add their MBL shares or folders to Windows Libraries for fast access… Windows says it does not allow adding network shares because these are not indexed (it does not say it cannot)…

There are some tricks around this, besides the lame and silly options offered by M$… there is a small command line program if one googles a bit…

The easiest, fastest, cleanest, and most effective is this one (which I found out by mistake):

1. Open Windows Media Player (I am using WMP 12)

  1. Select “Organize” > “Manage Libraries” > select a library

  2. You will find a dialog box “Change how this library gathers its contents”. Clicking on “Add” you should be able to select and add a folder on your NAS.

Unfortunately, this does not allow adding shares or folders to the “Documents” library, or to any Library, except the “media” libraries: Pictures, Videos, Music.

It’s something :smiley:, thanks for sharing.

I came across this same issue yesterday. I found the following solution in the Windows Help documentation:

  1. Create an empty directory on your local drive (for instance, c:\Share\Music)

  2. Add that empty folder to the library you want it in

  3. Delete that folder

  4. Open Command Prompt as an admin (you can right click the bottom left corner of the screen to do that)

  5. Create a symlink between your MBL folder and the folder you just deleted. For instance, "mklink /d c:\Share\Music “\MyBookLive\Public\Shared Music”

That should work for your media files and for your Documents.

yeah, that’s the lame solution given by M$… (it creates a symbolic or soft link, which does not behave very well when referring to a NAS… for instance I cannot see preview of my files, or sometimes I open a picture file and it does show… nothing at all!)

…and, by the way, the silly solution given by M$ is the one to make files on the NAS folders/share available offline… copying 2 TB on my 128 GB tabletpc… crazy M$!

I finally got around to testing this method, and, sadly, it didn’t work for me. For some reason, when adding folders to the Library following this procedure, the folders are “Read Only”, which causes issues with a lot of items that try to use the library (Windows can’t write it’s hidden system files, etc.).

Did you find a way around that issue? I tried editing the properties of the folder and unchecking “Read only”. Windows spent 30 minutes applying that change, but once it had finished, everything in the folder was still set to read-only mode. Thanks.