Adding a subfolder within my Public folder


I have been enjoying my WD drives (4tb My Cloud and 3TB My Book Live), but I just tried to create a new folder within a folder I created within the Public folder on the My Cloud drive, and when I go to add a folder, it says I don’t have permission or access to do so.  I tried adding it within the provided app they have you download, and it seems to work, but when I go to name the folder it just deletes it?  What am I missing here?  I have already created folders within the Public folder in the past, so I’m at a loss.

Strangely, when I go into a sub-sub folder within the Public folder, it will let me add a folder. So: 

Public>>>Music>>>Can’t make a new folder

Public>>>Music>>>Subfolder>>>CAN make a new folder

I suspect you have a variant of this problem:

Call support, ask to be escalated then ask for the patch to fix writing to public shares.

Worked for me after I submitted a support ticket and someone from WD called me last night and hooked it up.


Where is this [[DELETED]] patch?

Why tey do not deploy it on all the WDMyCloud they have infected to solve the big mess they produce with their **bleep**ing new version?

Hello, welcome to the community.

We have passed this along to support.

Does that mean a support person will get back to me? It’s something with My Cloud because I have everything duplicated on the My Book Live drive I have, and it WILL let me add the folder in the equivalent folder there within the Public folder.

Thanks for the replies.

Everytime I’ve contacted support (very rare because I factory reset my systems often to prevent layers on layers of firmware updates) and requested a call back…they’ve been very good about it. Now that my issue is PATCHED,  I’m in the process of making it fast again.