Add HD to DL4100

I purchased a DL4100 with 2 4TB HDs a while ago and am now trying to add 2 8TB HDs. I planned on setting them up as a second RAID 1 volume. I have read some of the other threads on adding HDs, but they do not seem to match what I am seeing.

  • I powered down the unit and installed the 2 8TB HDs. The system recognizes them. It shows all 4 HDs in the storage>Disk Status screen , but it does not appear to allow me to format just these new HDs I tried under Settings > utilities. It only allows selection of All Volumes or Volume 1 which is the current volume. I then

How do I proceed? I thought of taking out the 2 existing RAID 2 drives and booting up with only the new drives, then formatting and configuring them, but I am concerned that the 2 original drives may no longer be recognized when I do this.

Any assistance would be greatly appreciated.

Hi MDC,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


The link below will allow you to call support.

I had the same problem and just got off the phone with a support person. If you have not yet solved your issue, please respond and I will summarize the (surprisingly simple yet not intuitive) steps
Dan

You should post the steps here so everyone can benefit from your knowledge :slight_smile:

I would appreciate you sharing the solution. My understanding from tech support was that the MyCloud could not add an additional mirrored volume, like the old WDSharespace I have. I was told that I would basically have to wipe everything out and then the system would startup and setup the 2 4TB and 2 8TB drives as RAID 10 spanning a 4TB and 8TB drive and mirroring them. I am interested in any alternate solutions.’

Thanks,

Mike

Sorry for the delayed response

From the MyCloud management page, click “Storage”

Select “RAID” from the left frame

Click “Change RAID Mode” below the list of volumes

Then you can elect to change the RAID mode of the new drive to JBOD and do with it as you will. One option is to create a new volume, which the technical-support person said was impossible but is not impossible. That gave me the final configuration: 2 drives in RAID 1 mode (Volume_1) and another in JBOD mode (Volume_2) which I am now using as plain old Network-Attached Storage.

1 Like
  1. When you select “Change RAID Mode” there is another menu level which allows you to select the new drives and set them up as a second RAID volume? I have not tried selecting “Change RAID Mode” because I was not sure what the path was and if I could back out of it if I did not like the options.

  2. Can this can be done without wiping out the data on the current RAID1 volume?

  3. I am hoping that I can safely setup a second RAID1 volume using the 2 new 8TB drive like I was able to do with my old WDSharespace 4-drive unit.

Thanks for your assistance.

Come on Brandon - this is another one of those non-helpful posts.
People don’t come here to create a ticket and wait for an email.
Nor do they come here to have you tell them to call support.

It is very easy to have this simple Step-by-Step solution ready to PASTE into the post, and provide to the community.

Hi MDC, I checked WD’ site and found this:

At step 3 of the article, I would pick RAID1, and checkbox “Create new Volume”
It should then take you to a step where you pick the 2 new drives that are not setup in the existing RAID.

Good luck!

You are not helping MDC 3 months later. WD Staff here know nothing. Since it did not get a reply for 3 days he suggested calling product support.

You should simply start a new thread that explains whatever you want to do instead of blasting all these old posts

BTW Thanks for contributing, subscribe to the posts so you can offer timely helpful responses

MDC might have email notification setup.
so he may see the post/message.

I’m just to wrap up this loose end.

This all started with my quest to expand my dL4100 with new 10TB drives.
I’m appalled at how poor WD support is.

sure thing.
Someone is seeing the posts.

I’ll look into subscribing.

After reading the post I closed my eyes and pushed the button. I had a backup of volume 1.
Just followed the steps and it worked somewhat. Untill the formatting volume2 was 100%. Then it stopped. I could see the extra storage in the dashboard, and the two red leds below the drive bays where blue.
So far so good. But the on/off was still red.
As always when the program stalls I restarted manually.
The screen on the divice still tells me drive1 95%, and the on/off still red. But the dashboard says 6,2TB space.
Now I am going to search for the drives to be seen on de computer.

suggestions anyone?

hi,
you will have to make a backup before you proceed!!! all data will be lost on the discs.

The only thing to make an upgrade is to set the system on raid5+.
Then it will format all 4 discs! that is why you have to backup. And you need some patience; it took me 3 days.
Then the system hangs itself, and you need to stop and start manually.
After that you will see 1 volume with the available disc space.
Then reload the backup to your system.

have patience and good luck.
Cor