AD Users & Groups


#1

I can’t seem to get the ShareSpace to see AD users and groups. The 4T box I have has joined the domain correctly, I see it in the computer list in AD just fine.

When you try and permission a folder and refresh Windbind, nothing comes back other than the refresh sucessful message, but no users, no groups.

Tried talking to WD support, but they seem to have no clue why it isn’t working.

And ideas why it can seem to see anything in AD?

Jake


#2

Hi Jake,

I had the same problem. After getting the message “Refresh Successful” I could not see the AD users list. The thing I’ve done was to click on “Users” tab again and click on “Folder Share Permissions”  and all the users and groups were there. It is a matter of “refresh” the window :slight_smile:


#3

I’ve just tried to re-join the NAS to the domain and after that I lost the AD users and groups. The thing I’ve done to fix that was to deleted the computer account for the WD NAS, move the NAS to the workgroup and join the domain again. That solved the problem.

…but AD (Kerberos) and SAMBA seem to have problems when using AD users and groups. I get Access Denied to the share folder when using the domain account :frowning: I checked the time and it is correct on the WD NAS so I do not know what else is wrong.


#4

darchorz,

 

I tried your first note, that didn't seem to make any difference for me ... user/groups still come up blank. There has to be something screwy with firmware, too many people seem to run into the same problem. An older version of the firmware apparently works, though I have not tried that yet my self.

 

Jake


#5

I’ve got the latest firmware (2.1.96 with MioNet 4.1.0.0.171) and it seems that it works OK in terms of seeing AD users and groups. I cannot get the AD user/group to access shares at the moment. The workaround for me is to create a local user on WD Share Space with the same usernam/password as the domain account, give the local user account permission to the share folder, and map the drive under the domain account.

 I will keep trying to resolve it, though.

Do you know which firmware version works fine with AD integration? Can you download it as a file?

darchorz


#6

I’m running the most current firmware my self, but have never had any luck getting AD users/groups to appear.

The work around appears to a quick fix to get access to the share, but I have one application that can’t access the share, because it always use AD to verify and connect to the share, and hence my problem. I end up with a 4TB system that can’t be used for it’s original purpose.

I believe the firmware was 2 versions ago that apparently works and not certain if you can still download it or not, I’ve honestly have never looked to see if we have access to archived versions or not. I’ve got aothe rmore important issues to chase and only play with this when I have a spare couple hours.

Certainly let me know if you figure out something and I’ll do the same, should I get it working.


#7

Have any of you tried ‘ssh’ing’ into the machine?

When mine was still working I noted that there was a

auth=nosamdomain, wbnt4domain

(or similar) in the /etc/samba/smb.conf file.

I’ve not used those params before, but the nosamdomain seems like it said to

ignore any domain name and just use ‘users’ – not sure what the wb param did.

The ‘ssh password’ for your machine is given in your network settings ssh tab…might be

under the advanced settings. – can’t tell for sure right now as my ‘share space’ is completely

unshared right now – doesn’t respond to a ping! :frowning:

sigh – and no reset button! (to reset everything!)


#8

OK, I’ll have to take a look and see what’s there and investigate the settings there.

My ShareSpace is just a big paper weight at the moment … useless without domain users permissioned shares.


#9

big paper weight that is getting returned here…after wasting 3 hours on phone with tech support, they agreed the unit was dead.

(my reason for calling was to get way to d/l firmware from web, and image a new boot drive for the device myself rather than returning it – no way to do that and it only took them 3 hours to tell me this…)

sigh.