Activity light flashing continuously when My Cloud is turned off

How is it even possible that my My Cloud drive’s activity light can flash when the drive is off? I have had no end of issues since upgrading to OS5 about a month ago. Rather than go into all of them here I thought I’d mention this particular problem as I simply don’t unerstand it.

I turned off my drive using the SSH Button android app as I couldn’t access the dashboard at all. The power cable was still in, and as to be expected, the link light then went off, cloud access had already been turned off and the blue LED light went off. Yet somehow the activity light was still flashing furiously like it has done for the past 5 weeks since my upgrade.

Does this indicate something has gone wrong with my drive? The only thing I haven’t tried is a 40 second reset because it took a month to index my files the last time.

If you want to turn the My Cloud off, unplug the power cable to it after selecting shutdown/hibernation.

The reality is that for some My Cloud models when one “shuts down” the unit using either the My Cloud Dashboard Hibernate option or Shutdown option, or when using SSH (shutdown -h now) one isn’t really shutting down the My Cloud rather they are just stopping the operating system. Power is still flowing to the backplane/motherboard of the My Cloud.

I’m curious though as to what activity could be taking place. There was no link light up at that point and cloud access was off. No PC was connected so in theory no data could have been being passed. Does the activity light do other things?

Generally on the lower end My Cloud units the shutdown or hibernate command just halts/stops the operating system. Power still flows to the motherboard/backplane that the hard drives are attached to. Because of this on some units the activity LED or Ethernet port LED’s will still indicate activity. WD for what ever reason made the manufacturing decision not to include the ability to actually power off certain (or all) My Cloud models. Its why some or all do not include a physical power on/off button. WD even went so far as to rename the Dashboard option from Shutdown to Hibernate on some My Cloud firmware versions. At the following WD Knowledgebase Article they even indicate to enter a “power off” state on a Multi Bay My Cloud one may have to remove the Ethernet cable:

How to Shut Down a My Cloud Device

Multi Bay My Cloud Dashboard Hibernate Option


The Shutdown option in the Dashboard of multi-bay My Cloud products with firmware 2.11.133 and higher has been renamed to Hibernate . The Shutdown option is no longer available in the Dashboard.

To Shutdown a multi-bay My Cloud Devices from the Dashboard , follow the steps below:

  1. Access the dashboard of the My Cloud device. Please see Answer ID 22007: How to Access the Dashboard on a My Cloud Device for more information
  2. Select Hibernate from the drop-down menu
  3. Click OK on the popup window, asking to continue. A second popup will appear, confirming the Device is hibernating
  4. Once the unit has entered Hibernation mode , disconnect the Ethernet cable from the unit. The unit is now in powered off mode .
    To restart the unit, remove and reconnect the power cable.
  5. On some models, it may be necessary to press the power button after reconnecting the power cable, in order to start the My Cloud.

Thanks @Bennor
I was hoping that this might have given me a clue as to why my drive seems to be in an indexing loop but I have also tried powering off too (unplugged the power lead) and nothing is helping

I want to continue to use the remote access - that’s what I bought the drive for in the first place but when it gets to the end of indexing the dashboard is unavailable so I reboot (sometimes unplugging the cable, sometimes a 4 second reset) and then the whole indexing thing starts again. Actually, I say when it finishes indexing, but I’ve only ever seen it in the 90%+ - I’ve never been in the dashboard when the indexing reaches 100% so maybe it isn’t.

This OS5 update has been a complete disaster - especially as my certificate doesn’t work so I’m still not able to use the secure login option.

It also doesn’t remove files that I deleted off the drive. Incidentally, I have ceased moving files across briefly so as to avoid reindexing but it hasn’t solved the problem. I’m running out of options and will have to consider a 40 second reset but I’m not convinced this will resolve the issues.

Generally indexing is a seperate issue. If, you haven’t done so already, see the following WD Knowledgebase articles on indexing. It appears the workaround at the moment to deal with indexing, that cripples the unit, is to turn off Remote Access/Cloud Access and disable Twonky if it is installed under Apps. Such a workaround however will not please those who need or want remote access to their units using the web portal or the WD My Cloud OS5 mobile apps for iOS/Android.

My Cloud OS 5 Cloud Access Content Indexing FAQ

Best Practice for My Cloud OS 5 Cloud Access and Indexing

Just a quick update. I unplugged the 1Tb USB drive from the MyCloud and the indexing issue seemed to be resolved. So I plugged the USB drive back in but disabled the cloud access on that particular share and things seem to have settled down.

It may be that the indexing on the USB drive was still not complete (although I thought it was) or it might be that the USB drive was causing the looping indexing, I don’t really know.