Active Directory permissions breaks after firmware 1.04.05

I have tried integrating with Active Directory with every firmware after 1.04.05, without any success, because users are unable to access their shares.

I am able to join the domain correctly as well see the list of users in the EX4 dashboard. The problem is that if I create a share and give permissions to a user, that user is unable to access the share. The same goes for user groups permissions.

Is Anybody else having the same problems ?

There are multiple threads about the similar issues, but without a proper solution.:weary:


Does resetting the unit make any changes?

See if the following link helps:

No I tried system resets and a factory resets, and the results are the same.

I have this problem.
Do not have access to folder from domain users.
Public access or no access. :frowning:

Windows 2012 r2

mine to did a lot of factory reset. Got a new firmware.

I feel Very disappointed with WD for this Product, This Product totally cannot support AD already,