Acronis said I needed a WD SSD, but it was hooked up

I attached my new WD SSD to my DELL laptop with a SATA cable, but Acronis didn’t see it because it kept saying I needed to have a WD drive installed and referred me to the Acronis webpage for purchasing.

I ended up going in the Windows 10 Disk Management piece, right clicked in the volume area of the SSD and set it as a partition. Then Acronis could see the drive and allowed me to clone to it.

Then I had a ton of read errors while cloning. After naming all the partitions with letters, I ran chkdsk on each partition and found nothing. I even tried another check disk program and it found nothing as well. Tried a second cloning package and it found all the bad sectors too. I ended up recloning with Acronis and moved on.

The clone looked ok except it didn’t have a bootable partition, which i tried to create to no avail. I didn’t want to change it from GPT to MBR to make it bootable with diskpart. My old drive is GPT so I wanted to stick with that. Restarting Win10 said there were problems…I could boot from the old drive, but was making no progress.

Stepping back from all the minutia I saw the chance to physically install the SSD which magically changed the drive letter from E to C and made it bootable. I guess Windows made it happen. IDK.

Win10 now starts in less than 30 seconds instead of 15+ minutes and appears to be fully functional. It’s great to have a usable machine again.

I could have used some very basic directions for installing the SSD. As it is, I had to discover what worked and spent a ton of time on it. I’m not seeing any simple documentation even here, on the forum, so maybe this post will help somebody else. I’m wondering now if I should have installed the SSD first and cloned from my SATA attached old hard drive.