Acer laptop non responsive when connecting to external hard drive?

Booting in either normal mode or safe mode, if the external USB hard
drive is connected, the laptop is not responsive. But if the USB is not
connected, the laptop boots up fine. If I connect the USB after the
laptop boots up, then the windows will start to become non responsive.
It detects the hard drive but becomes non responsive.

The hard drive is actually from my primary laptop. It failed to boot up
so I am trying to access it as an external from my back up laptop.
When I used disk management to see the status of the hard drive, it says
there is a cyclic redundancy error. When I did a startup repair on my
primary laptop using a usb drive, it says the MBR had an error and the
bootrec commands did not work because the drive could not be accessed and
the device was malfunctioned. Not sure if the hard drive is broken…I
do have files on it.

I have reinstalled the USB drivers and my back up laptop is free of
viruses and malware…chkdsk and sfc scannow ran with no problems. sfc
found and fixed all errors it found on the first run, but afterwards
found none. But even after all scans, the external hard drive still
makes the laptop non responsive.

Any ideas? Let me repeat, the laptop can DETECT the external hard
drive, but it cannot access it. I can run chkdsk /f /r f: from the
command prompt (F is the drive letter) but the command prompt will just
stay there not doing anything…the scan process will not start.

The external hard drive is a Western Digital and WD’s website has a Data
Lifeguard Diagnostic for DOS tool but when I tried it out using USB, the
tool could not detect my external hard drive. It detects my internal
hard drive which is a Hitachi but not my external.

My Computer detects the external. It just shows the drive and the
letter but does not show the amount of space the drive has. Disk
Management detects the drive but shows the drive as Uninitialized.

Kinda confused at the moment.


Sounds like the unit lost the partition. Does the drive works on a different computer?

Someone suggested using linux to access the external hard drive, which worked. Saw my files. I ran a command to fix the MBR but got an error message which I forgot, then I ran a command to fix the NTFS file system which ran successfully. The file system was not clean and it was fixed successfully. Tried booting from it on my primary laptop and this time, the drive had a label on it, no MBR error, but now a new error: corrupted registry. So gotta figure out how to recover the registry or repair the corrupted entries.