Accidentally fixed my WDTV crashing problem

My box was locking up increasingly frequently (when not in use, never when playing a film). Locked up maybe every few hours to maybe three or four days at random (required a re-boot every time).

I’ve replaced my nearly full (USB attached) 2TB WD Passport with a 3TB WD Passport - problem solved, it’s now rock solid.

I’m pretty sure the 2TB drive is OK. I’ve previously tried re-formatting it and copying all my files back onto it. It didn’t make any difference to the reliability.

I can’t believe having a nearly full drive causes problems.

Odd???

did you even bother to run Data LifeGuard Diagnostics

to see if there was a problem with the drive ? eg. bad sectors

1 Like

Thanks for that, I didn’t know about the diagnostic tool.

I’ve done a ‘Quick Test’ and the 2TB Passport passes. The docs indicate - “a high level of confidence… defect free”.

I’ll do an ‘Extended Test’ when my PC is free for a few hours.

Edit: Extended Test… ‘Pass’.

If that is the problem … then you’ll be back to square one when you fill up your 3TB

As a test, have you tried freeing up some space on the 2TB … to really see if that really was the problem ?

Also, have you run Windows CHKDSK on the 2TB drive … to fix any possible corrupted data ?

A hard drive is not like a drawer you can cram full. Best practices with a HD is fill it no more than 90% or so. It needs some free space for HD kinds of operations.

the so-called 90% rule would only apply to OS “System” Harddrives … not “Removable” Storage

i have a 4TB with 177GB free … still works fine on the WDTV, Raspberry Pi 2, Android Box etc

I keep a backup copy of all my films. I tried formatting the 2TB drive and re-copying all the files back. This did not fix things, I guess that’s as good as running CHKDSK.
Since I never get a failure whilst watching a film, the problem was an irritation rather than a show stopper (Ha!). If the problem returns with the 3TB drive I think I’ll just leave the box powered off until I need to use it. A bit of a bind since the WDTV takes about 4mins in total to boot up and sort itself out.
Fingers crossed it stays reliable. Since it’s working fine with the 3TB drive i’m reluctant to spend any more time trying to find out why it was failing with the 2TB drive.

fair enough …

i guess i should’nt comment any further … since i don’t use WDTV anymore

4min boot up time ? … yikes ! (my RPi2 takes about 10-15 seconds to boot up with a 4TB) :grinning:

Just out of interest what have you got that replaces the WDTV?

already told ya in the previous post :wink: