Accidentally deleted touch


#1

I’m a dumbo and accidentally deleted /bin/touch /usr/bin/touch from my 1st Gen WD My cloud. I tried doing:

apt-get install --reinstall coreutils
Reading package lists… Done
Building dependency tree
Reading state information… Done
Reinstallation of coreutils is not possible, it cannot be downloaded.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Is there another way to get touch? I don’t have another 1st gen WD my cloud that I could copy it from.

Thanks!


#2

Do NOT do a apt get on these My Cloud boxes, especally the first gen versions. These boxes use custom Linux firmware modified by WD. Doing an apt get often causes the My Cloud to brick. The first gen v4.x My Clouds use a different format (page size?) than standard Linux so modules typically have to be configured/encoded for it.

One suggestion. Try reinstalling the firmware to see if it rebuilds the missing folder(s). Another option is to perform an unbrick but that may cause loss of all user data.


#3

Another way to do this is to get the latest firmware .deb file. Extact the file to a folder. Then you can
mount the root.img file and copy the touch executable. This shows one way to extract the files.
https://linux-tips.com/t/how-to-extract-deb-package/169

The command to mount is mount -o loop

Then you can copy /bin/touch /bin


#4

That worked!

extracted firmware
mounted root.img
scp touch

Awesome. Thanks!


#5

Thanks for the info, that was the first time I tried using apt-get on my cloud. I won’t do it again!


#6
  1. Select the search box in the taskbar, enter device manager, and then select Device Manager in the results.
  2. Select the arrow to the left of Human Interface Devices.
  3. Right-click HID-compliant touch screen, and then select Uninstall. Note. …
  4. Restart your Surface.