Accessing the WD MYcloud from windows server 2019

Just upgraded our server to MS server 2019 and need to access the WD MY cloud for backing up. However trying to access it comes up with the error " You can’t access this shared folder because your organization’s security policies block unauthenticated guest access…"

Any simple way to fix this ?

Many thanks for reading

Create an actual user account on the mycloud, and disable public shares.

See the user manual

on page 46, “Creating a private share”

I can access the mycloud from my PC but the 2019 server refuses to connect due to the policy. It’s a public share but if I change it to a private one with users setup for full access it makes no difference and it won’t connect saying the same warning message on the server. I’ve found a way to disable the policy but i’d rather take an alternative route if possible.


Does “net use” work?

Open CMD run as Admin
Open GPO editor gpedit

Move to Computer Configuration → Administrative Templates → Network → Lanman Workstation and select Enable insecure guest logons