Accessing shared files needs wdtv reboot

I am having issue since long time on my WD TV Live Streaming (WD TV Live 3rd Gen)

I can access network files on windows 7 pc and watch movies. However if I turn off wdtv then after next turn on I can access network files, can browese them but if I select any file (movies) all I can see is rotating arrows and movie will not start.

The solution is to reboot the wdtv and then I can access files again and play them.

The workarround would be to leave the wdtv after watching movie so it will turn off automatuically after 3 hours. So on next turn on it will work.

In the past I had WD 2nd gen and had same issue - and this was reason why I change to 3rg Gen.

I use windows 7 and apple extreme router, Wdtv is wired connected.

Any ideas?

I get the same issue

I am reading mp4 files of a Lacie NAS as a windows network share

Some how i think it is to do with when my NAS goes to sleep, but i have not quite pinned the issue down

every time i use my WD TV LIVE i restart device… its so annoying that I often just use my laptop and dont even use the WD

btw my PC is never in sleep mode

i tend to think that it may be something about multiple login from wdtv to pc/nas (in your case)

things i tried:

  1. completely new pc server with reinstalled windows (polish version) and different hardware (bord, disk, memory)

  2. tried windows 7 and now windows 8

  3. firewall turn off

  4. all settings on sharing up to recommended in forums

  5. tired 2 wdtv of different generation

  6. always updated firmware

what was not changed are:

  1. routers (airport extreme + express)

  2. wires