Accessing MyBookLive Duo from Android phone

My WD MyBookLiveDuo is connected to my router via cable. Until this morning on my android phone I could go into ES File Explorer, go to the LAN tab and scan for devices. This would display the ip address for the drive and when I click on that, the drive would open, all my files/folders available.

I tried to copy some 1GB+ movie files from NAS to phone wirelessly. This failed, don’t know why. Now when I go into ES explorer and do a scan the MLD does not show up at all. It is still accessible from my windows pc over wireless

I have  rebooted both the phone and the MLD, makes no difference. I’ve also tried form another Android device and that can’t see the MLD either

Any help much appreciated

Rebooted router and now ok


Glad to hear that you were able to get the unit working.

We continue to make progress restoring connections to our My Cloud and My Book Live servers, but some users continue to experience intermittent connectivity and transfer speed issues.  We sincerely apologize for this inconvenience and we are working very hard to resolve these issues and resume normal service for everyone as soon as possible.  We thank you for your patience.