Accessing EX2100 shares while offline from within LAN

Hello everyone,

I have an issue with my EX2100. I have had a network outage in my area over the past few days and have had no internet coverage outside of mobile data. I wanted to use my data from my EX2100, only to discover that the shares do not work while there is no internet connection. Why?

Since I am on the same LAN as the device, shouldn’t it work?

To clarify, both I and the EX2100 are connected to the same router. I have also tried to hardcode the share by adding the local IP address as a network mount (i.e. \\ShareName), and still no success. However accessing the dashboard (in a web browser inputting works.

Is there a setting I need to enable for the shares to be accessible? Why isn’t this working? This is very frustrating to not have access to my own data off my own network, just because I am offline…

Thank you in advance!

On the Mac try using SMB://, on the PC use \\ShareName

Please read my message again. I tried this exact approach with no success.

To be as clear as possible, my EX2100 is reported in the router as having local IP
I have attempted to mount \\ShareName (where Sharename is the name of a valid, existing share that works as intended when I have an active connection to the internet)
If the router’s connection to the internet doesn’t work, none of the devices connected to the router, via cable or Wifi, can connect to the EX2100 shares.
The device portal, however, works as intended if I access the IP address in a browser.

This is a very severe issue! I essentially am completely unable to access the data on my drive! Completely unacceptable!

Edit: the \ symbol is apparently an escape character, so I cannot post the “correct” connection formula. Rest assured that I am using TWO \ before the IP address. Again, this works fine when the router has an internet connection, both with the device namespace, and/or with the local IP. It only fails spectacularly when there is no internet access in the router.

WD, please release a fix for this immediately!

Hello Sidefix,

I just came up with exactly the same issue.
Same situation as you.
Internet failure for a complete week, and no access to the SMB shares on my EX2100.
The main problem is that ALL of my backup jobs failed. They use the smb shares to deposit the backup data and I had to work a full week without any backup, and without even the possibility to recover any backup !!!
When connecting to shares through command line I got error 64 and error 121, “access denied”.

At the second internet came back, all the shares were available again.
Why is this ? FTP works offline, access via the web interface works offline, video streaming worked offline. Why not SMB shares ?

I temporarily manually disconnected my router from internet for testing purposes and a couple of seconds later the shares were just … gone ! The NAS disappeared from the network section in windows explorer, and I could not access smb shares anymore. As soon as I reconnected the router it came back.
What is this useless behaviour ??

Thank you for anyone who replies to this particular issue.
Best regards