Accessing Drive without WD Mycloud Case

Hi guys,

last night my WD Mycloud 1 Bay Drive literally went up in Smoke yesterday. I was accessing it when suddenly the connection dropped. On checking I found out that there was a little steam cloud and distinctive burnt smell coming out of the devices airvents.

As there is no warranty left on it I opened the case and removed the WD Red to check it. The burned smell came from the motherboard, the harddisk seems fine.

So I connected the drive via a USB Sata adapter to my laptop to check. I found a tool named Data Lifeguard Diagnostic on WDs pages and installed this. It identifies the drive correctly, shows it as healthy and as WD Red 8TB but says that there is no logical volume on it.

So I booted from a Linux live disk and that also says disk is healthy and ok but also no logical volume.

My question: Is there any way to recover my data? I do have a backup but I would still like to know if all is gone. of if I still can access my stuff.

I somehow cant imagine that such a case of an electrical failure leaves the drive intact but deletes the logical volume…

Any ideas on this?

Cheers, Arthur

If you are simply looking to access a My Cloud hard drive from Windows then one generally needs to install a third party Linux driver so the Windows Operating System can access the Linux formatted hard drive. See the following discussion for more information.

One such third party software that will allow one to read the data on the My Cloud hard drive in Windows:

For recovery of deleted files or corrupted hard drive. Use the forum search feature, magnifying glass icon upper right, if you haven’t done so already. Search for “recovery” (ex: There are a number of past discussions that cover how to attempt data recovery (with varying degrees of success) when one has deleted files from the My Cloud hard drive.

I installed a tool for accessing the drive on Windows and also tried native Linux via boot cd.

Problem is it shows an empty partition but everything else seems to be ok.

Which partition is being shown as empty? There should be one partition (sda4) that is an EXT4 partition that contains your user data files.

The big main partition. Here are some shots of the diagnosis tool provided by WD:

You can see that in the lower half of the window there are two logical volumes of the two internal disks but non of the WD Red connected via USB SATA Adapter…and Linux Mint also says it can’t mount the volume as there is none…

There should be up to eight partitions on the My Cloud hard drive. What does Linux Mint Gparted show? Below is an example of what a single drive My Cloud might look like in GParted.

In the example, SDA4 is the main user partition that stores the user data.

Edit to add: Also the WD Diagnostic tool may or might only be reading Windows partitions not Linux partitions.

Dunno, that link for downloading the tool was sent to me by WD support as I had tried to get sth fixed by warranty, which sadly didnt work.

Will check Gparted later today after work and then post it.

Here’s what Gparted shows…Ive got a bad vibe.

Is there an open source recovery tiol available for Linux?

Not looking good. What specific My Cloud unit do you have? Is it a first generation v4.x firmware MY Cloud (p/n number on the bottom of the My Cloud enclosure ends with "-00). Or is it a second generation v2.x firmware My Cloud (p/n number on the bottom of the My Cloud enclosure ends with "-10).

Note that if you have a My Cloud Home that is a different device than the My Cloud line of products.

Use the forum search feature to search for past discussions on how to recover data from a My Cloud drive. Chance are with all the partitions gone or with the boot record corrupted it will make it a bit more complicated/hard to repair and or recover any data from the drive.

I don’t have any specific recommendation of Linux recovery software (maybe someone else does). Best one can do I suppose is search for Linux data recovery programs that can recover data from EXT4 partitions and that can recover/fix boot errors on Linux drives.