Accessing data on removed drives thru Linux issue

I’ve been unable to mount and access data on either the A or B drives in my MyBook World EditionII.  After numerous calls to tech support, it was recommended that I install Linux (via Ubuntu), and connect either of my drives to my PC via a drive adapter cable.  I was successful installing Linux, and both drives are recognized.  As one of the steps in gaining access to the data partition of either drive, I was told to enter the follow in a command window:

sudo mount -t ext3 -o ro /dev/sdd4 /mnt  (sdd4 was the name given the data partition by the system)

However, I get an error message saying the following:

mount: wrong fs type, bad option, bad superblock on /dev/sdd4, missing codepage or helper program, or other error. In some cases useful info is found in syslog - try dmesg | tail or so

I’m not a programmer or Linux user, so this is a foreign language to me.  Would anyone have some helpful advice based on what I’ve provided?



Ok, I have a bit more information that I hope someone could help me with.  Using the command in my previous post, I am able to mount two of the four RAID volumes on my faulty hard drive and access their data.  Unfortunately the data volume with my photos, videos, and music isn’t one of them.  Querying with the dmesg command, It tells me that the system cannot find the ext3 filesystem for the data volume (error: can’t find ext3 filesystem on dev sdd4). I’m not sure if this is the salient problem here or not, but any ideas on how to restore the ext3 filesystem, or another work around would be welcome.

Thank you

This worked for me…

Thanks for your response.  I’ve been pursuing this same question at the site as well.  Through the help of people there I was able to successfully get to my data and save it.  You can see how this was solved here:

I hope this helps other people stuck in the same predicament.

1 Like