Access nil

Hi & thnx for replying
OK if I go to wd2go it asks for email & password, I enter this and it says no devices available. I have done a full reset and know my email address is correct, as it told me I already exist when I tried to re enter the info after the reset. have reset my password as well so I know that is correct.
if I enter the ip address I get to the dashboard.
In settings there is no “remote access” there is a cloud access, this is on, go to configure it is in auto…
I don’t have anything that says connection status, been through every page in the dash, nope not there !
Gone to cloud access at the top, nothing there to say connected or not.
There is and always has been only one user, and that is admin with no password. So let’s add a user. entered my email and password and now it let’s me log in to access the cloud, there is nothing in my shared folder but I can click on public and see the files now.
now rebooted macbook and logged in again, now have a connected notification when signed in as admin to the ip. However if I sign in as the user I just created all I can see is twonky, me. public & wdsync, not the full dashboard.
should I sack off the admin and make my email and password the only log in ? or can I do it first, make sure it works, then remove admin ?
Feel we are getting somewhere now, thanks for this, this is the kind of help non techy people need

What model/version My Cloud are you using and what is the firmware version? The firmware version is typically listed on the main home Dashboard page under Firmware.

On a v04.04.02-105 firmware single bay My Cloud below in the red box is what appears for the Cloud Access section under the Dashboard > Settings > General page. Note the Connection Status line which shows how or if the My Cloud remote access is connected and working.

Below is how the Dashboard > Cloud Access page looks and where it indicates its connection status.

When one connects through the web portal they DO NOT access the Dashboard, rather they see a listing of the Shares on their My Cloud that they can access remotely. When one connects to the My Cloud using Mac Finder or Windows File Manager they are generally accessing the Shares of the My Cloud NOT the Dashboard.

If the My Cloud remote access isn’t indicating connected for a status then remote access through the web portal most likely will not be able to access the My Cloud.

It’s a my cloud, 4tb single disc, Firmware I updated last week when I got it, it is 2.11.140 and says it is up to date.

and here is what the connection status looks like

Now on my imac if I go to finder and click the WD it signs me in as a guest. Don’t know why but I seem to be able to access my cloud as a guest, but not myself… Weird

Just tried to play something on itunes and it tells me it cannot find the library, tried to point it at the cloud and it refuses to see it, have signed out of the finder sidebar, now cannot sign back in. Can access through WD software, but not through finder. Software tells me I am signed in, finder tells me I am not… Aaaaaarrrrrgggggghhhhhhh

Guest will give you access to the Public share, but not your private user share.

You need to connect using your user credentials. I recall Macs giving trouble with persistent credentials, but, since I don’t use one, I can’t help.

I’d suggest getting the basics of Finder access sorted, before trying things like iTunes. The MyCloud is a complex beast, despite the marketing puff. It’s best to take it step by step, gradually building your understanding. My suggestion would be:

Basic file server, with private shares, accessible using OS native tools (e.g. Finder, File Explorer).
Applications using file server access
Media server (if you want that)
Backup (if you want to use WD tools, or use third party tools)
Remote access using WD apps (adding Devices)
Remote access using
Using Linux via SSH to optimise the performance.

The wd setup tools try to do everything at once, and don’t involve the user, so the user doesn’t learn how to control their device properly.

The ‘mobile devices’ setup path featured on the Quick Start Guide, using the Dashboard, is, IMHO, the better way for a user to set up the device if they want to understand how to manage it, combined with careful reading of the manual (you need the correct manual for your Gen2, v2 firmware device, thanks to WD’s crazy product development approach).

What Mac OS are you using? El Capitan? If so there are known problems that Apple introduced with El Capitan and the My Cloud. See this thread for lots of discussion:

It is generally recommended one “map” the Share or My Cloud to their local computer. The My Cloud User Manual ( gives basic directions on how to “map” the Public Share to a Mac or Windows PC. Or see the following WD Support document:

It is becoming confusing as to what your doing and where your problem lies. Is the problem with remote access? Or with local access?

It is important to understand the distinctions and differences between each method of access. When one accesses the Dashboard with their web browser they are not accessing the My Cloud remotely. The Dashboard is how one configures their My Cloud. When one uses the web browser and goes to or they are accessing the WD portal that allows remote access to their My Cloud Shares. When one uses either Mac Finder or Windows File Explorer they are generally accessing the Shares on the My Cloud through their local network.

Using a Mac, try the following to access the My Cloud: Finder > Go > Connect to Server > smb://IP Address of your My Cloud
If that doesn’t work try: Finder > Go > Connect to Server > afp://WDMyCloud.afpovertcp.tcp.local

Remote access I have never had !
Local access is becoming smaller by the minute.
One day I could go to finder, or Cmd+Shift+K which gives me a list of servers, click on wd my cloud and away we go.
Next day I had lost all access through finder.
I am on El Capitan, if that is the problem I can restore to former time and OS.
I can only access the dashboard by putting the ip address into browser
I can only access the drive by the WD software, which is an improvement as I couldn’t do that yesterday.
Both of these are local, I have never repeat NEVER been able to access it from anywhere else other than my house, my router.
trying the two options above asks me for name and password.
My name is already there, I have tried with capitals & without, I have tried the short name, I have tried my email address, they all fail.
I have stuck a paper clip in the reset for 40 seconds, gone thro the whole process of setting up again, same thing.
Would it be worth doing a reset and signing in with a different email address, user name and password ? There is a lot of stuff I have put on it, but nothing that cannot be put back on it, or possibly format the drive and start over, seems drastic measures.
Mapping the drive, sounds like a fun afternoon in store…
WD help have still not replied to my request of three days ago either !

I’m confused. If you are just setting up the My Cloud why are you giving it an email address? Generally to setup and access the my Cloud from the local network, using one’s web browser, they just need a user name that one created within the My Cloud and the password that one created within the My Cloud. The email address is only needed for two reasons; one is for remote access, the other is for alert email notifications if one enables that option within the Dashboard. To access the Dashboard one does not put in their email address in the name field unless, for what ever reason, they used an email address as the user name when setting up the My Cloud.

Typically when one does a 40 second reset it is supposed to reset the My Cloud administrator account and its username / password. If upon next Dashboard access you are prompted for a user name and password, use the name “Admin” and leave the password field blank.

Somewhere in the set up it asks for email address, I have tried to connect through finder with First name, first and second names, user name, and email, they are the four items I added at start up.
When I try to log in to wd2go my email address is already in the name field, if I try putting anything else in there it says “Enter a valid email address.
(Note: Use your registered email address)”
and won’t let me in to the dashboard. Have to type in the ip address to access. When I go in that way the user name is admin and the password is blank. If I put Admin & blank into wd2go I get the above message…
Another 40second paper clip coming on I can feel it,

Just done another 40seconder.
Went to the WD software on desktop and it logged me in to dashboard with Admin & blank
Went to wd2go logged me in with email and password. There’s an improvement !
Went to finder tried to log in - Nada, connection failed.
The thing is up and running now, it’s just so infuriating because I could log in thro finder much easier than going to wd2go & now I can’t.
Can log in on android tablet with my cloud software, will try remote access from My son in laws tonight,


Have you looked at the thread on the ElCapitan problems?
Which version of ElCap are you running?

When you do the dashboard setup, it asks you to accept T&Cs, and then asks you to give an email address. You can skip this stage by pressing ‘cancel’ and it will continue with the setup.

@normski4ash, STOP trying to access your My Cloud through the website UNTIL you figure your problems on the local network with trying to access the My Cloud. Get the My Cloud working properly on the local network FIRST before messing around with remote access through the web portal.

Have you tried accessing the My Cloud Shares as mentioned above using smb:// or afp:// on your Mac’s?

If using El Capitan have you reviewed the huge El Capitan thread to see if anything in there is of use in your situation?

Have you tried mapping a Share to make access easier?

IT WORKS ! finally I have access from outside home . thanks bennor you are a star. Thnx a million

What was the solution to fixing remote access?

Just another 40sec reset, didn’t do anything else. Let’s hope.

Hi Bennor,

Now up to my 12th 40sec reset…
WD have answered my cries for help, finally, just sent them some screen shots of the firmware version etc. Hoping for a rapid reply…
Since I proclaimed “it works” I have had to press the reset button twice a day. Reset this morning to get it working, (still no access from finder) got to work, it’s working from afar,

Ooops, sorry, to continue,
However by lunch time it had stopped again, infact my android came up with error 403 whatever that is…
Come home tonight, try to access from the software tells me the SSL certificate is invalid, tell it to continue and it lets me in.
Try to access the dashboard from wd2go tells me no devices available.
Access the dashboard from the IP address works fine.
Strongly suspect I have a duff budgie, Normski

You can’t access the dashboard remotely, only locally.

Have you read the user manual yet? [Edit: I take that back, since you say you’ve read it cover to cover. But if you misunderstand dashboard access…?]

Sorry, yes, I am going round and round in circles I’m completely lost !
If I go wd2go and try to access the drive, be it locally or from afar I gat that error message, " No devices available "
Trying to access from wdmycloud.local/ says " This site can’t be reached ".
If I enter the ip address I go to the dashboard, only way I can get to it ever !
The first week I could access from finder, now I can’t tells me connection failed.

@normski4ash, like I suggested previously focus on just your local network issue right now. Spending time accessing is just wasting time at this point if you are having local network problems accessing the My Cloud.

Who is your broadband provider? If AT&T some people recently have problems with AT&T Uverse routers that require them to put a switch or hub in between the My Cloud and the AT&T router.
What firmware version; v3.x/v4.x or v2.x is your My Cloud using? (Firmwarev ersion is listed on the main home Dashboard page.)
Do you have a non Macintosh computer you can use to test with on your local network to see if that non Mac computer has trouble accessing the My Cloud?
If you can access the My Cloud Dashboard, have you configured the My Cloud for a Static IP Address (Dashboard > Settings > Network > Network Services > Network Mode) or have you configured the broadband router to issue (or reserve) the My Cloud a Static IP Address?

You have two separate issues. Local access and remote access. Address and fix the local access first, before tackling the remote access issues.