AC3 (Dolby Digital) Doesn't Passthrough Properly

Hello, I have a WDTV Live Streaming.  I have it connected wirelessly.  I have MKVs with 48kHz AC3 audio tracks that the unit does not play properly; the video works properly but the audio is nearly silent (static picks up during playback).  The AV unit is a Sony STR-DE835, with optical inputs that support DTS and AC3.  The WDTV unit is set to work with a AV unit that accepts AC3 and DTS in the Audio/Video Output settings.

During playback of the affected files, the AV unit displays the correct information about the audio track, a blue light indicates that it is receiving an optical input, but no sound is forthcoming.

The optical cable has been swapped and verified with another device (PS3).

If I set the WDTV to Stereo instead of Digital Passthrough Via Optical Only in Audio/Video Output settings, the sound works albeit in stereo.  If I play a file with a DTS track, the unit works as intended.

1 Like

Hi, i have the exact same problem. AC 5.1 not working on optical DTS working just fine. :frowning:

This is a very annoying error, that i hope can be fixed.

Btw. it works in 1.04.xx firmware. But that firmware has other problems, so thats not at good solution.


Have you tried rebooting the SMP after checking the supported audio formats in the SMP audio menu? Mine was acting the same way until I made check boxes next to DTS and Dolby Digital, then restarted the SMP and it worked.

Yes, I rebooted.  Yes, I reset to factory defaults and set everything up again.  Yes, this device is a flaky **bleep**.

Yep same problem, I’ve tried everything, it only works on 1.04.12 firmware for me.