Absolutely horrific Experience with Passport SSD 1TB

First of two problems… and this is frustrating…

first problem is the website being so archaic like you would expect to create a new topic under the forum that you wander into but the create new topic is greyed out or is it just me as I can imagined being banned from the SSD section. Under my favourite forum the My Cloud Home the Create a new topic is normal, it is just the WD SSD Drive forum that the create a new topic that is greyed out. So I wander back up to the top of the forum and there the “create a new Topic” is. fine and then I can select the forum of where I post under which by the way has over hundreds of forums in alphabetical order and good luck if you were to scroll and select a forum and luckily there is a search function that allows me to type SSD and there it is… so who writes this Website software? I mean the other last time I complained was about where the log off button got moved to because it took me 15 minutes on clicking all submenus looking to sign off. This is worse than Windows where they decide to hide the start menu. Stop it already. I mean nobody wants to post in a moving archaic forum where you cannot create a new topic and when that happens they are not going to look for a way to post and thus your forums dies.

Anyway my second and main problem is my purchase of 2xWD Passport SSD and how problematic they are.

Many years ago I bought two WD SSD 1TB drives and had a horrible experience with them and ended up arguing with Best Buy on returning them. Thankfully I did get my refund.

I then bought a rival Samsung SSD 2TB and never looked back until today.

I was going to use my Samsung SSD 2TB on my new gaming machine but I needed some SSD’s to replace my Samsung on my Mac for use with Calibre so I looked around to see the new 1TB WD Passport SSD cards on sale at BestBuy so I bought 3 of them thinking of using them for various tasks on my MacBooks.

Absolutely horrible experience as I spent 3 days troubleshooting all kinds of problems.

First problem was a message that I haven’t seen since the time that I bought the two 1TB WD SSDs and that is “Disk Not ejected Properly”. I had multiple of these messages as I was copying my ebooks from one SSD to another. Yup I also thought about power supply and my hub does have a external power and that wasn’t the problem.

Absolutely not, I will not be troubleshooting your Hardware for you WD…

Something about your SSD drives don’t quite fit in with Apple Hardware.

I thought it might be the Mojave OSX so I moved the SSD over to OSX Monterey and there it sat for a couple of days doing nothing until today (a couple of days has passed between the first test and today) where I thought I would spend the day copying over the ebooks again on a newer OSX Monterey… and there it froze again… it said two days to copy 200GB of data… and this is your fastest SSD of speeds up to 1000MB?

Good grief… WD… take two SSD and mount them on a powered Hub and test…

This happened several years ago and it is still happening today through multiple OSX. Not my MacBooks, Not my OSX and not my software.

Oh yeah one more thing… after installing WD Discovery my Mac just froze…

again I ask… who writes your software? let me know… WD Discovery gave me problems 3 years back on mounting the SSDs. Today WD Discovery crashes my Mac upon install on a Mojave Mac.

Lastly as if anyone or WD cares, I did format the SSD drives to Ext4 Journal so there are no NTFS software involved. Just straight OSX file copy. It does work from time to time, but it definitely stops working when you try to copy from SSD to SSD and from that time on, everything is in error. Also I did use the disk utility to fix all errors and that reported no errors. I bet it is the same controller that you created back in 2019 that is still causing the same error today.

All 3 WD SSDs are going back to Best Buy and hopefully there won’t be any arguments…

Pass it on to your tech guys… and make sure you hire someone that uses a Mac because I believe that half your users are Apple Fan boys.

Soooo I took the drive out of the box again and connected it to a MacBook with OSX Big Sur installed and formatted it to Ext4 Journal and simply copied 160,000 items from my NAS over to it. The straight Mac file copy works fine.

It is still copying but for now it seems to be working fine.

Might not return…

update: it looks like the errors starts when you have two SSDs connected on a powered USB hub.

yup…

Screen Shot 2022-07-01 at 12.21.30 PM

Hi @Ralphael,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:
https://support-en.wd.com/app/ask

so here is the verdict @Keerti_01

after extensive testing… swap swap swap… test test test… swap… swap… test

On my system MacOSx Monterey and Mojave, I cannot copy from SSD to SSD on the same breakout USB-C hub.

Also I cannot run a P2P on the USB SSD itself either. The P2P does work on My Passport 4TB 2.5 hard drive but does not work with the My Passport SSD. Files are locked and gets corrupted and any simultaneous read and writes are locked by the drive.

However on my fresh install Big Sur, a SSD to SSD copy does work…

and the difference between all these systems may be the NTFS for Mac by Paragon Software. On the Mojave system the Paragon App has been deinstalled but perhaps not completely. This might have been the app that caused the problem 3 or 4 years ago with the two WD 1TB SSD drives also of which I had tried to copy from one SSD to another. When doing so the system will lock and one or both of the drive(s) will eject and remount giving out the system message “Disk not ejected properly”. I believe the Paragon NTFS app came from one of the WD Drives that allowed us to format and use NTFS on a Mac.

No idea if it is the NTFS app that is causing all the problems but given that on a fresh OSX Big Sur that has none of my history (a decade of Mac usage) is on it or cloned to it and the copy from one SSD to another SSD does work,

thereby this isn’t a WD SSD problem.

update:
I have uninstall NTFS paragon and using an app that searches my hard drive for everything “paragon” and scrubbing it clean. I also deleted the ISCSI Initiator that I was using to test the EX2 Ultra ISCSI drive.

But to no avail… and I get these two system messages… as you can see that copying from SSD to another takes 51 minutes for a 13GB file which means it is locked and you get the “Disk Not Ejected Properly” message after waiting for a minute. Something in my system is preventing me from a SSD to SSD copy and I don’t know what it is.

Screen Shot 2022-07-06 at 5.00.30 PM

Screen Shot 2022-07-06 at 5.02.13 PM

So the solution to absolutely horrible experience with Passport SSD 1TB is not the Passport themselves and with a fresh install of the MacOS, plugging in two SSD can and will copy to each other.

The MacBooks that have had problems with, have been using Migration Assistance that transfers all my Data and apps from my decade old Mac Mini along with every single app that I have used along with way including NTFS and ISSCI. My MacBooks is full of history and full of garbage from migration. Back in the days of the Mac mini I do remember installing a driver that handled the TRIM because Apple wouldn’t allow us to install our own SSD so TRIM wasn’t supported. No idea whether that driver got copied through all the generation of migration assistant. One would think not but you never know.

Another software that does affect the speed of copying and writing is BlueHarvest which deletes all the superfluous metadata generated by the Mac but the problem is that when copying a very large file, a temporary file is created for the copy and BlueHarvest immediately deletes it and so… I was watching a 1GB file that fought for several hours making me think that I had a hard drive error. The resolution, of course, is to ensure that blue harvest is not running. Blue Harvest is needed to clean up all the metafiles on a million pdfs, music scores, photos as every single file creates another metadata file. Turn it off when copying a file.

Although I have uninstall the NTFS and ISCSI apps, probably some remnant code still ties up the USB bus. It is also possible that apps like my Logitech Bolt and Logitech Options might be to blame as the Bolt app does lock up my computer and requires a cold boot. How do I know? It was the most recent install and when I uninstall the Bolt app my MacBook no longer intermittently freezes.

I haven’t started fresh with a fresh install of the OSX but a simple file copy from SSD to SSD was tested on a fresh install of the OSX. What I mean is that I haven’t started installing all my usual apps onto the fresh install to see which app might be affecting the SSD to SSD copy.

I did use one of my new SSD (I bought 3 of them during the Best Buy sale) for a backup and restore of moving/copying one of my broken Macbook to another identical MacBook so I can take my broken MacBook into Apple for repairs. Instead of 4 hours of backup the SSD only took about an hour and a half. Very Nice.

I have 4 MacBooks on a 4 x HDMI switch with a 2 x Logitech mx keyboard that switch between 3 MacBooks and it is the same with my Logitech MX anywhere mouse that can also switch between 3 MacBooks. I also have a gaming PC that one of my keyboards can switch to also.

Why. am I posting all this info? well the passport SSD 1TBs are great for Quick backup and restores . They are also great for use in ebook management Calibre. I plan to use a SSD for my gaming PC just for Steam.

Now that I know that the WD SSD works most of the time I love the speed of just copy and go.

Sometimes it does not work properly when you plug in a second WD on one of the affected OSX you get a message that the “Disk is not ejected properly” then the NO SSD will work properly. You know when you try to copy a file and it tells you that it will take 20 hours. The SSD is now dirty and I’m not sure how to fix this but it is something to do with my old old OSX install.

But if you plug in one SSD and you use it as it is intended… copy files to and from the SSD, then everything works.

Once I get my repaired MacBook back (it has a bloated battery), I might start building up my work desk from a fresh install and hopefully I can get two SSDs to copy to each other in that system. SO CASE CLOSED.