AAM on Noisy WD Drives


Wondering if anyone can help.

Just bought a new pc from a retailer…all well and good but HDD is quite noisy…bit distracting to be honest.

Model is WD6400AAKS

I know there is Automatic Acoustic Management software out there and have tried one or two but dont seem to work. I installed SiSoftware Sandra and said there is the AAM function but it has been disabled. The two softwares I have tried have either given me message ‘error with AAM’ or amends it but doesnt seem to have an effect or doesnt even recognise the drive.

I am not one of these people who are quite interested in transfer speeds but for a new pc you shouldnt hear it seeking so much although fast shouldnt be that loud.

Is there anyway to recitfy this or is the drive just faulty?..is it something to do with the BIOS?..read somewhere about AHCI having an effect but not an expert about this area.

Any help would be appreciated.


Have you tried HDDScan (Windows)?


… or hdparm (Linux)?


For the meanings of the various AAM levels, see Table 58 on page 254 of the following document:


A value of 128 (= 80h) is the minimum noise setting, while 254 (= FEh) is the maximum performance setting.


Thanks for reply and link to hddscan. Tried to use that program but doesnt seem to let me change any AAM settings. The IDE features part of the program which would help me change aam settings is blocked out for that drive. Not sure what that means?

In regards to HDPARM…I have windows 7 machine, I know LINUX is different platform, would this work for changing in windows and what is procedure?

I downloaded SiSoftware Sandra and it told me that there is a aam feature in this drive but it is disabled, wondering how I can get round this. I know from SiSoftware Sandra that it is aam setting is 254 just now.

i have tried the Hitachi tool but it doesnt work either.

Any further advice would be appreciated.


I suspect that HDDScan is prevented from accessing the drive due to a problem with a Windows driver or API.

As for whether a Linux application can do what you need, the ATA standard stipulates that “enabling or disabling of the AAM feature set, and the current AAM level setting shall be preserved by the device across all forms of reset (i.e., power-on, hardware, and software resets)”.

This means that any changes you make with hdparm will survive a power cycle. However, you may find that HDAT2 would be better suited to the task. It runs from a bootable CD in a DOS environment.

HDAT2/CBL Hard Disk Repair Utility:

User’s Manual HDAT2 v4.8:


Ran and downloaded as you suggested the HDAT2 software from boot. Doesnt seem to work as when I set it off to run the program in DOS it gets to the part ‘switch AHCI to IDE…OK’. Then it stops working saying ‘device not supported or not present’ then it crashes when it gets to ASPI detection and stops working and I have to restart system. It is confusing me somewhat and where to go from here?

Could this be a BIOS issue to do with AHCI and IDE settings?.

Again further help would be appreciated.


You could try configuring the SATA controller in BIOS for legacy or compatibility mode. This will make the drive look like a PATA HD.

Otherwise, post your question to the HDAT2 forum:


Tried your legacy and compatibility mode solution. No facility for that on motherboard BIOS. Only to change to Native IDE which I tried but BIOS didnt like that and Windows would not boot nor find the HD drive. Could it be that the drive itself is SCSI?..and if so solution to try?..I read a blog there from a site saying AAM can be done with mainly IDE devices and a friend did it with his hitachi drive using hitachi software and but he just told me his interface was IDE,dont know if this will be any help?.


The WD6400AAKS is definitely serial ATA, not SCSI. It may show up in Device Manager as SCSI, but that’s just the way Windows’ drivers work (Don’t ask me to explain, because I don’t understand).

I believe the reason that Windows won’t boot after the BIOS changes is that it was built with a SATA driver, not IDE.

I’m at a loss to understand why your drive can’t be seen by HDAT2, but if you wish to try Hitachi’s Feature Tool, here it is:

Hitachi Feature Tool Usage Instructions:


Already had tried hitachi tool but didnt show HDD as didnt detect it.

Could it be that the firmware on the HDD has locked the AAM function from being changed as read on another blog that they come either default in performance mode (254) or quiet (128)?.

HDAT2 does function to a degree but as I said in previous post it gets to part ‘switch AHCI TO IDE = OK’ then stops working. Could this be to do with the SATA driver?

The computer I bought was from ACER, could they have locked this?

I am at a loss to what to do from here. I have read other blogs and with this drive people have seemed to be able to change it but doesnt seem to be the case here. Its quite strange if you ask me. I have tried HDDScan,CrystalDiskInfo and Speedfan and they all either do not detect the HDD,say SMART function isnt available or aam isnt available yet on SiSoftware Sandra it says its a feature of the drive yet isnt enabled.

Again any further help would be appreciated.



As nothing else was working I decided to give HDAT2 another try. Managed to get it to change the AAM settings!!..none of the other programs I mentioned in previous post worked anyway. Think I downloaded HDAT2 lite program and this may have been incorrect, downloaded full HDAT2 program and put it onto a bootable cd…

I changed the settings in BIOS first from AHCI to IDE then after used boot disk with HDAT2 full program and the WD drive was found unlike before…I managed to enable the AAM but wasnt straightforward to find and changed it to quiet mode…then i exited program and went back into BIOS and changed the setting back on sata controller to AHCI (Had to do this so that windows would load again,as with IDE set it wouldnt load up).

Thanks for all your help and steering me in right direction and if this solution helps anyone else please forward it on.


Is AAM enabled or disabled by default? My WD1002FAEX-00Z3A is also noisy these days. I have HD Tune Pro and I dont if when I was checking the settings I enabled the setting to high performance 254 or is it suppose to be 128 from the factory?

I received my WD1002FAEX today (strictly speaking: WD1002FAEX-00Z3A0 and yesterday), so I can confirm that AAM is set to high performance, i.e. 254.