A Working Solution for Network Problems


#1

hi guys!


i have already bought my WD TV Live.


as all of you after i got my media box i had problems. the main problem was that my WD TV Live didn’t see the shared folders on my PC. and i googled millions of things. here are my system and what i have:


1. HP nx8220 notebook PC

2. Win XP Pro SP3

3. Airties RT 211 ADSL router modem

4. ADSL internet connection

5. WD TV Live

6. iPhone 3GS 32 GB

7.Cables


settings:


1. my pc is wirelessly connected to the ADSL router modem

2. WD is connected to the ADSL router modem via cable.

3. iPhone is wirelessly connected to the ADSL router modem


here are the results of my quests. do all of them to work the network streaming from PC to WD TV Live:


1. initially, update everything you have. Firmware, drivers, SP, whatever. after all reboot everything.

2. Give static IP to WD TV Live, PC, and the router modem. (Detailed below)

3. put your PC in da work group which is called WORKGROUP (see related MS knowledge pages for how to do it. it is easy and with no possible problem)

4. open WD TV LIVE network services from settings screen on WD TV LIVE menu from TV. Reboot the box.

5. SET TO AUTOMATIC AND START  those Windows  services (detailed below):

  1. Computer Browser
  2. Network DDE DSDM
  3. Network DDE
  4. Server

6. Reboot PC

7. Open/Activate Guest account on the PC. (Detailed below)

8. Share the folders(directories) that have media files in them (Detailed below)

9. Finally Reboot PC and our little monster :slight_smile:

…Ta da!

you should now be able to see the shared folders of the PC from WD TV Live. Remember to reboot PC, media box, and ADSL router modem after settings to have a power cycle and let changed settings to kick in.

now the details

Giving Static IP to Router Modem:

you will do this according to brand of your ADSL router modem. you can find how to on its website. so i won’t deal with it here. it’s simple and almost the same in all routers.

initially TURN OFF the DHCP in the router modem

the important thing is that your Gateway should have the IP and subnet mask as follows:

192.168.2.1

255.255.255.0

.


Giving Static IP to PC:

Navigate::Start\Control Panel

Double Click::Netwok Connections

Right Click::<the connection u use>

Click::Properties

Select::Bla Bla TCP/IP in the dialog Box. and Click::Properties

Select::“USe The Following IP address”

Now enter something as follws:

IP Address: 192.168.2.2

Subnet Mask :255.255.255.0

Gateway:192.168.2.1 (remember you have assigned this above)

Select::“USe The Following DNS Server address”

Prefered: 8.8.8.8 (google DNS service, this is)

Aleernative:8.8.4.4


Giving Static IP to WD TV Live

go to network settings. you know where it is :slight_smile: anymore.

Enter exactly the same information with your PC except IP Address. Give IP Address as follows:

IP Address: 192.168.2.3

(the rest of numbers are same with the numbers in your PC settings)

now you have ubderstood the IP issue:

Gateway: 192.168.2.1

The PC:192.168.2.2

WD TV:192.168.2.3

Altering and Running Windows Services

NAvigate:Start\Run

1. Type in: “services.msc” without quotes and Click::OK

2. Double Click::<The service you are interested in>

3. From the dropbox Select::Automatic

4. Click::OK

5. Right Click::<The service you are interested in>

6. Select::Run

do these for all the services i mentioned above.

Opening Guest Account

this is important because our WD TV Live will be a Guest in our PC, IMHO. and this is very easy since Guest account is a system account. it’s already there.

Navigate::Start\Control Panel

Double Click::USer Accounts

an account with the name “Guest” should already have been there. ( if it is not there then  check MS website for it or simply google it). Click on it. then click to activate it.

Sharing a Folder

1. open Windows Explorer.

2. from the menu bar, Navigate::Tools\Folder Options

3. in the Appearance tab clear the checkbox assocated with the item “USe simple file sharing (recomended)”. Click::OK

4. navigate to and select the folder which has media in it.

5. right click on it and select “Sharing and Security” or simply “Properties”

6. Click to the checkbox indicating the permitions to let the folder be shared in Sharing.

7. Assign accessing, reading and running permitions to Everyone, and Guest groups.

i think that’s all.

i hope it helps…

sorry for bad english…