A new netflix glitch

I have had this for a litte over a week, I updated the firmware the fist time i connected, and i am running cat5 cable to the box .

at first everything was working find, i am hooked up with hdmi and the movies i played, I aloso tested movies played thorugh the network and netflix, and everything was working fine.

Now the drive had 400meg of movies, and few pics, and songs, and connected with a external 500gig wd drive, that has been working flawlessly now.

Now when i play netflix, usually something for my grandson, it will play so long, and then like blank out for a couple seconds and thne continue. I have tried removing everything but the box and it will do the same. I cannot understand why as from my testing, it does it with all the videos that i have tried. and this is just for netflix.

any suggestions

the network is good, test good

can play movies off internal drive

off the external drive

through the local box and folders

1000meg switch

cannot understand why, as i can play the netflix on the playstation and it works fine, using the same cable that was used for the wd box…

There was a new firmware release today. 

Support Netflix 3.0 Application.

Lawrence wrote:

There was a new firmware release today. 

Support Netflix 3.0 Application.


post your experiences to the link below.


Wrong link - this is the hub board

Post here


1 Like

Thanks richUK

for the fix