8TB external drive slow to open initially

I have a WDC WD80EMAZ-00WJTA0 8 TB drive (WD Elements) that’s about 2 years old. If it hasn’t been used in a while, when I click on the icon in file explorer, it may take about 15-20 seconds to open while Windows 10 says “working on it”. Once it does initialize, files can then be quickly accessed as expected. Things I have tried include disabling windows search (indexing), disabling USB suspend in the Power Plan settings, unchecking “allow computer to turn off USB devices to save power” in power management in device manager (USB root hub), tried a new premium cable, tried all USB 3 ports on the rear of the PC, Crystal Disk Info reports no errors nor does WD Diagnostic Tools. CHKDSK reports no errors. Some of the folders on the drive do contain large amounts of data (one folder is over 50GBs full of pictures). The drive is barely a third full so nowhere near full capacity. I do have a setting enabled in the BIOS to shut off USB ports when the PC shuts down so that external devices won’t stay on after shutdown requiring me to manually turn off the PC via the power supply. Nevertheless, I can’t see why the drive wouldn’t initialize on startup and be ready to instantly open. At least one other person on another forum said their large external drive also takes about the same amount of time to initialize if not used for a while (hour or so). Any ideas or things I might have overlooked?

Solved. The problem was the power supply. Used the adapter from an old My Book 4 TB external drive and plugged it directly in the wall instead of the outlet strip. Drive now works like new.