8tb Drive with a WD TV Media Player - black one


#1

Hello I have a WD TV Media player (the one without the memory) and i have purchased an 8tb drive (Seagate) I was wondering if this would be accepted or if this is too high a drive to use on my media player, its just that I can return it if the box is unopened and I just wanted to ask first, many thanks are sent in advance


#2

if your WDTV Media Player looks like this … then 100% NO (maximum is 2TB)

But … if you have the late model ones 2011-2014 (like below)

Then … i don’t know (can’t afford a 8TB HDD) … will have to let someone with $$$ answer


#3

I think mine is slightly older as the remote is larger, the one you showed me lookes like my old one(which was grey) but  i have reformatted my 8tb with easus partition master and it has registerd the drive on my media player, so i am now  in the process of copying files so will let you know how I get on


#4

well good luck … just make sure you format it NTFS with GPT partitioning

i got my 4TB WD HDD working fine with the 2014 WDTV Media Player that way


#5

What is GPT partitioning is that another type of software?


#6

https://msdn.microsoft.com/en-us/library/windows/hardware/dn640535%28v=vs.85%29.aspx

http://www.partition-tool.com/easeus-partition-manager/help/initialize-to-GPT-disk.htm


#7

Well, 8tb is working with the new 2014 WDTV

http://community.wd.com/t5/WD-TV-Media-Player/Seagate-Archive-8TB-is-working/m-p/867196/highlight/true#M2516

I was able to use a 3TB drive in the old WD TV by using this software:

http://www.verbatim.com.au/en_AU/products/hard-drives/desktop/47673/3-5-store-n-save-desktop-hard-drive-usb-3-0-3tb/drivers/asset/8231


HELP! My Book - WD Player
#8

That is the one I have, I thought I had fixed it, when I formatted it, it “came up” on my media player (it was still blank) but now after I have copied some files to it, it does not “appear” anymore, so still looking for solutions please, but thanks for all your help coming in


#9

Can confirm 8TB drives works for the latest WDTV. I have 2x Seagate Backup Plus externals (NTFS) and it was a very simple Plug n Play experience.

I didn’t eject one drive properly (button on the remote) and the next time I plugged it in it wasn’t showing. Quick error check fixed it no problem.

Only issue I have with the 8TB is how long it takes to compile the media library. Have yet to have the patience for this to happen as more than 5 hours is a bit much (maybe having 7,000 movies is the real problem!)

Finding it easier to plug the drive into the laptop and use the Play To feature as there’s no search function available until the library is compiled.