6TB Red - Win 7 64bit only recognizes 1.5gb


My system (Windows 7 64bit) will only recognize 1.5TB of this drive. I’ve initialized as GPT. I have a 3TB drive on this system that recognizes the full 3TB but I don’t recall if I did anything special to set this one up.

Any suggestions would be appreciated.


How is the drive showing on Disk management?

Please see the following link for instructions on how to check that.


Thanks for the quick reply ERmorel,

As it sits right now it’s listed as a “Basic drive with 1492.91 GB Online”, and there is only one partition set up as GPT.

Using diskpart I did a “clean” on the drive but still came up with same size. It is connected directly to the MoBo, Asus P6x58D-E.

The reported capacity is consistent with a 32-bit LBA limitation. This could be in BIOS or in the SATA driver.

How is the SATA controller configured in BIOS? RAID mode or AHCI mode?

If the motherboard has more than one SATA controller, are the 3TB and 6TB drives attached to the same controller?

Have you updated the SATA controller driver (eg Intel RST) to the latest version?

Does BIOS recognise the full drive capacity?

Note that if your driver has a 32-bit LBA limitation, then your 3TB drive will be a data loss time bomb that will go off when you try to write data beyond the 2TiB point. It would interesting to see how a disc editor such as DMDE (freeware) detects the 3TB drive’s sector range. If it detects an 800GB drive, then this would be of serious concern and would confirm the existence of a 32-bit LBA limitation.

Hi fzabkar,

  1. SATA controller set to AHCI

  2. Two controllers - 3TB on 3Gb (Intel ICH10R) and 6TB on 6Gb (Marvell PCIe 9128)

  3. Have not updated driver. Currently using the older Intel Marix Storage Console 8.9. However, it displays 6TB


  1. Yes, 6TB recognized by the BIOIS.

  2. Had me concerned about the time bomb comment. Does the following mean that I’m ok. I’m very close to exceeding 2TB.

In my previous reply, for the Intel Marix Storage Console I forgot to include the window that actually shows that it recognizes 6TB


Sorry, it took some time for your images to be approved, but I can’t see anything wrong. Strangely, just yesterday I received a private message at Tom’s Hardware from someone whose two 4TB drives have become “raw” after writing data beyond the 2.2TB (= 2TiB) mark. S/he suspects that the system was affected by a 32-bit LBA limitation.

That said, I’m a little confused by your statements. You wrote that the 3TB drive was attached to the Intel ICH10R SATA controller while the 6TB drive was attached to the Marvell PCIe 9128. However, your screenshots show that both drives are on the Intel ports.

If you have switched to the Intel port after using Diskpart to initialise your drive on the Marvell port, then perhaps you should re-initialise your drive on the Intel port. It may be that the Marvell driver is affected by a 32-bit LBA limit whereas Intel’s is not.

I’m assuming that this is a photo of your motherboard:


My mistake stating the 6TB HHD was on the Marvell PCIe 9128.

A couple of pic’s didn’t get through in my previous posts as I failed to remove serial numbers. I made the necessary changes and reposted them including output from DMDE. DMDE reports 3TB for the other drive – is it safe to assume it’ll be fine writting beyond the 2.2TB mark?

Is there anyway to be certain that once a drive is initialized/partitioned/formatted successfully beyond the 2.2TB mark that it’s safe to use the full drive. Seems odd to me that you’d get no warnings as you prepare the drive yet, you have this time bomb just wating to get you.

I have no personal experience of this problem, but feedback from end users suggests that they run into problems after changing their configurations in some way. They may successfully set up their drives in the proper environment, and then unwittingly switch to a configuration with an insidious 32-bit LBA limitation. The change may be as simple as switching from AHCI mode to RAID mode in BIOS, or it could involve switching SATA ports, or reverting to an earlier SATA driver.

AFAICT, Windows looks in the partition table to determine the size of the logical volumes but does not check whether these volumes can fit within the physical drive. In fact I have seen one instance where Windows thought that a drive’s capacity was 4TB when in fact it was only 2TB. This was because the partition table had a second, bogus 2TiB partition.

BTW, your revised images haven’t yet been approved, so I can’t see them.

I believe my issue is now solved but only time will tell for sure.

My plan was to update the Intel Matrix Storage Manager to the newer IRST. However, after I uninstalled IMSM and rebooted the standard windows drivers kicked in and the full drive size was recognized.

I have a question about IRST. I believe its main advantage is increasing drive performance. If this is true and I’m satisfied with how things are running would there be any other reason to use it? I’m a little hesitant about installing another piece of software that I’ll have to keep up to date – obviously this hasn’t worked very well for me in the past.

BTW, thank you fzabkar. I had totally forgotten about Intel’s storage manager, it’s been hidden in that background. Although, I wonder what had actually changed on my system that caused the problem, hummm.