6TB MyBook USB 3.0 disconnects and becomes 'unrecognized' under heavy load

I have a brand new 6TB My Book connected to a brand new Dell OptiPlex 7040 PC. I have used the WD utilities to format the drive just to make sure it’s ‘plain as it gets’. No encryption, no weird anything.

If it’s just sitting there it’s fine, I have two partitions created, and directories created for backups of the main machine. I left it overnight for a few nights doing nothing and it stays fine.

However, I tried to push a full backup of about 100GB to it and about 1/2 through the MyBook disconnects and Windows 10 pops up and says the USB device is not recognized. Nothing fixes it until powering off the MyBook. Then it works, until you try actually copying data to it. A little data is fine, a lot of sustained data breaks it.

For the record, the unit’s firmware is up to date (I checked). Windows is up to date. It just acts like it chokes on too heavy a load. It’s a 6TB disk, it needs to be able to handle a large backup!

Brand new everything almost right out of the box.

1 Like


Make sure the drive is plugged in directly into the wall outlet to avoid any power issues.

I also recommend running a diagnostic using WD DLG.

Data Lifeguard Diagnostic for Windows

Will check power and diagnostics and retry the large backups. thanks for your help!

So that didn’t work, the drive USB connection fails every single time. Pretty much always around 98 GB, but had one run to almost 700 GB before failing. No reason at all. Have run all the diagnostics, everything is peachy. Power is plugged directly into the wall. All drivers are up to date. Drive just chokes and falls off USB and requires power cycle to reappear. It seems the drive just can’t keep up a sustained data write for any length of time.

Any other ideas?

I also purchased a 6 TB WD My Book which drops out in Windows 10. I’ve contacted support at WD, Microsoft and HP and no one seems to know why it happens despite implementing all of the fixes (wall power, power management, etc. I’ve been using WD drives for years for my backups and don’t ever remember having this problem. I can back up to the drive but at some point it disappears from File Explorer, Disk Management and the hidden USB icon on the taskbar. I need to power down and reconnect to get it recognized again.

Yeah, mine never has worked reliably. I gave up on the drive (and WD) for backups. It’s definitely something to do with too much data over the USB port–if I let it just sit there like a bump on a log doing nothing it remains connected (tested TWO WEEKS of continual connection and light use). Push any large amount of data through it and it falls off the connection.

Too unreliable to use. So I have a high capacity paperweight on my desk now.

1 Like

Thanks for the heads up. I’ve accumulated several WD drives ranging from 2 TB to 6 TB and will have to figure out what to do at this point since I need reliable backups for my business.

Late but maybe relevant…

I had the same problem with a Seagate USB3 drive. Hung/dropped with a large throughput.

Turned out that it worked/works fine via USB2 but on my crappy Etron USB3 hub it played up. I connected it to a USB2 port where it lives today working fine.

This was 5 Revs of the Etron drivers ago so maybe it was them and has been fixed but if you’re also an Etron user then look into updating the drivers and see if that helps.

I’m having that same problem. Maybe it’s Windows 10, I going to switch the gizmo to my other computer which is running Vista and see if it does the same thing.

After month of tech support communications with WD, I was advised that the dropping out of the 6-TB drive was abnormal behavior for the drive and that I should return it. I was 30 days into a 15-day return policy with Staples but they honored the return in any event which argues for purchasing in your local community. The proper operation of the external drives is critical for backing up the hard drive. I used EaseUS religiously on a daily basis to backup the system, the hard drive, the email and files and successfully created a bootable emergency disk for use. Recover did not work, however, despite repeated communications with EaseUS and I was out of luck when I received the error “Critical Error: Your start menu is not working. We’ll try fixing it the next time you log in” which is the Windows 10 equivalent to the “Blue Screen of Death” in former versions. I now back up to a 4-TB WD drive with Windows Backup and Restore (Windows 7) which is still included in Windows 10 and which seems to be working although I’ll find out for sure if I ever have to restore again.