6TB EX2 doesnt work...multiple replacements from WD. No Help from customer support!

Background: Bought an EX2 shell…and two 6TB Red HD’s. Could not get the drive to read both drives at the same time. Called Tech support and was told the shell was defective. Got a replacement and the same issue occured with the new Shell. Sent back the Shell and both 6TB Red HD’s to WD. I have brand a brand new shell and 2x brand new 6TB Red HD’s.

When i drop in the drives both HD lights blink red rapidly. The dashboard hangs at “insert HD’s”…it never processes the HD’s so that i can click “continue” to prep the drives for the system.

Same/same when i try to use the setup program…it sees the device…but it will never let me “continue” to prep the system.

The new shell i have i know has an older firmware since the dashboard has the black background…but i cant get into the dashboard option to update the firmware even if i have HD’s in the shell or not.

Hs someone ran into this problem? if so please help. When i sent the system back to WD i just wanted them to access the unit and prep it so it would work. Their, lazy, solution was just send out new items. I have been trying to get his to work since November…yes, almost 4 months trying to get this to work.


I haven’t seen this case before on the community.

Have you tried accessing the dashboard on a different browser or resetting the unit?

I have tried to connect using the dashboard and the download-able program. I tried it from my Alienware Laptop with Windows 8…upgraded to windows 10. Used IE, Edge, Chrome and Mozilla.

Also tried on a desktop with different browsers.

I am on my 4th EX2 enclosure and 2d set of HD’s. I have to assume it has something to do with both HD’s being brand new and not “prepped” for the EX2. I removed all partion allocations…nothing. I made the partition Linux-swap…nothing. FAT32…nothing. etc etc etc.

The first set of HD’s i had i was able to configure and access one of the HD’s at a time. But the system would not recognize when both where in the enclosure. So, i can have Drive 1 in Bay 1 and i would have no problem access/writing to it. I could take Drive 2 in bay 2 and read/write…but i got all red lights when i dropped both drives in.

I got the new replacement enclosure and HDs in the mail this week. I also got an accidental second enclosure. Both brand new. The one from Dell has the firmware with the white background…when i go to the dashboard it tells me to insert the HDs…i do that and hit “continue”…it says updating for 45 seconds-ish…then goes back to teh screen that says “insert HDs”

The replacement enclosure from WD has the older firmware with the black background. I log into that dashboard and it says enter HD’s…however, the HD lights on the enclosure are rapidly blinking red…and i cant hit “continue” on that enclosure.

WD had me write zeros to both drives in Jan (took 40 hours for each drive). nothing.

I will be calling WD Level 2 support on Monday. For the 3-4th time. I just want to send it to WD and have them configure it and send it back. But since i bought the enclosure separate from the drives…they wont do that becasue it is considered “different products”.